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PREFACE 
 

 In these lecture notes I apply the COMSOL Multiphysics 5.3a finite element 

numerical software package to present the fundamentals of the numerical modeling from the 

selection of the appropriate module, via building the geometry, prescribing the initial and 

boundary conditions, discretization, solving the problem to visualizing the solution. After a 

brief theoretical summary of the operation of finite element method, I suggest to follow the 

Introduction to COMSOL Multiphysics which facilitates step by step to acquire the basal 

functions and capabilities of the program by a typical ‘multiphysical’ example. The main 

body of the course is getting an insight into the numerical phrasing of a given practical or 

theoretical geophysical problem, thus several topics in Geophysics, such as vertical electrical 

sounding, magnetic surveying, induction borehole sounding, borehole exchanger, solute 

transport in groundwater flow, thermal and thermochemical mantle convection etc., will be 

discussed. These notes were primarily written for geophysicists, however it could be useful 

for both students and modelers who are interested in scientific research. 
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1 FUNDAMENTALS OF FINITE ELEMENT METHOD 
 

 Finite element method (FEM) was developed to solve partial differential equations 

(PDEs) and integral equations. The method is especially useful and suggested, if 

 the geometry of the problem is complex (e.g. racing car in wind channel), or 

 the areal density of incoming or outgoing data is strongly variable (e.g. meteorological 

observations). 

 

1.1 Historical background 
 

 Originally, FEM was developed to investigate the elastic and/or structural behavior of 

tools having complex geometry in engineering. In 1941, Hrenikoff introduced rectangular 

mesh, one year later Courant applied the triangular discretization. Since 1950’ structure of 

airframes has been investigated by FEM, and from 1960’ FEM started to spread in civil 

engineering. In 1973, Strang framed the exact mathematical description of FEM, and proved 

that it is adaptable to compute and solve arbitrary physical problem, e.g. Electromagnetism, 

Fluid dynamics, Heat transport. 

 

1.2 An example for the functioning of FEM 
 

 Generally, a FEM solution consists of three main steps: 

 Transformation of the original PDE to variational/weak form. Usually, it is simple, it 

can be done analytically. 

 Finite element discretization of the weak form. 

 Solution of a large-sized linear algebraic system (LAS). 

 As an example, let us take a 1D boundary problem, where 

 0)1,0(]1,0[)()("  xuandxwherexfxu . (1.1) 

Obviously, this problem can be solved by integration of the equation, but u’’(x)+u’(x)=0 

cannot be done. 

 

1.2.1 Weak form 

 

 First, Eq. (1.1) should be transformed to weak form. Let us multiply both sides of the 

equation by any smooth function v(x) that satisfies the boundary conditions, that is 

v(x=0)=v(x=1)=0. Then, it should be integrate for the whole domain, we get 

  

1

0

1

0

)()(")()( dxxvxudxxvxf . (1.2) 

Integrating partially the right term, 

    

1

0

1

0

1

0

)(')(')(')()()( dxxvxuxuxvdxxvxf . (1.3) 

The term in the bracket is equal to zero due to the definition of the base function v(x), so the 

weak form of the original differential equation Eq. (1.1) is 

  

1

0

1

0

)(')(')()( dxxvxudxxvxf . (1.4) 
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It can be proved, that the solution of the original equation Eq. (1.1) and the weak form Eq. 

(1.4) is equivalent, although the verification is not trivial (e.g. Hilbert transformation, Riesz 

representation), and not essential for this course. 

 

1.2.2 Discretization 

 

 Let us define a smooth base function system vk(x) that satisfies the boundary condition 

at x=0 and 1! It can be 
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where k=1..n. Figure 1.1.a illustrates the 1D base function system, which linearly varies 

between zero and one. 

 Using vk(x) the unknown solution u(x) can be discretized, 

 
k

kk xvuxu )()( . (1.6) 

With this transformation, the unknown vector uk should be determined instead of the unknown 

function u(x). Figure 1.1.b shows the relation between the solution u(x) and the solution of the 

discretized problem (right term of (1.6)). 

 Turning back to the weak form of Eq. (1.4), the right side can be rewritten using the 

discretized solution of Eq. (1.6), 
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kk . (1.7) 

 

Figure 1.1 (a) The base function set and (b) the illustration of the solution of the original (u(x), 

red) and the discretized problem (blue). 
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Since the constants can be extracted from the integration, the right side of the discretized 

weak form is, 

 kj

k

kjk

k

k Ludxxvxvudxxvxu  

1

0

1

0

:)(')(')(')(' . (1.8) 

Here, Lkj is the so-called stiffness matrix, which can be calculated from the base functions, 

 
1

0

)(')(' dxxvxvL jkkj . (1.9) 

 The known function f(x) can be discretized similarly to the unknown solution u(x), 

 
k

kk xvfxf )()( , (1.10) 

thus the left side of the weak form in Eq. (1.4) is 

 kj

k

kjk

k

kj

k

kk Mfdxxvxvfdxxvxvfdxxvxf  

1

0

1

0

1

0

)()()()()()( . (1.11) 

In Eq. (1.11) Mkj is the so-called mass matrix that can be computed by the integration of base 

functions, 

 
1

0

)()( dxxvxvM jkkj . (1.12) 

So, we managed to discretize the weak form using the linear base function system vk(x), 

 kj

k

kkj

k

k LuMf   . (1.13) 

 

1.2.3 Linear algebraic system 

 

 In order to highlight the LAS, it is worth rephrasing Eq. (1.13) into a vector equation 

from, 

 TT
MfLu  , (1.14) 

where T denotes the transposed vector. It is clear from Eq. (1.9) and (1.12), that matrix L and 

M can be calculated from the base function, while f is a known vector obtained from the value 

of f(xk). The unknown solution is the vector u, which should be determined by the solution of 

the large-sized LAS in Eq. (1.14). 

 Finally, the solution of a PDE was reduced to the solution of a LAS. The method is 

practical (i.e. time- and memory-consuming), when the structure of L and M are simple. In 

case of PDEs, these matrices are sparse matrices, that is the most of the elements are zero. It is 

instructive to calculate the elements of M in the given example. 

 Figure 1.2a reveals that M and L are zeros, when xk and xj are far from each other. 

More precisely, 

 10  jkifLM kjkj . (1.15) 

It means that non-zero elements are grouped in the diagonal and next above and below it. In a 

word, M and L are tridiagonal matrices, 
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where elements Akk and Bkj are obtained from the integration of vk(x)vk(x) and vk(x)vj(x), 

respectively (Figure 1.2.b and c). 

 It is really funny to derive the elements of M. Using the definition of the mass matrix 

from Eq. (1.13), 
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Let us perform the integration, 

 

1

1

3

)(

)(

1

3

)(

)(

1
3

1

2

1

3

1

2

1












 










 


 







k

k

k

k

x

x

k

kk

x

x

k

kk

kk

xx

xx

xx

xx
A ! (1.18) 

After some algebra we get 

 

Figure 1.2 Illustration of (a) the base function and the structure of the mass matrix M including 

(b) the diagonal and (c) the non-diagonal elements. 
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When the discretization is equidistant, namely xk+1-xk=Δx is constant, then 
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2 x
Akk


 . (1.20) 

 The Bkk+1 non-diagonal elements can be expressed from the multiplication of the 

decreasing part of vk(x) and the increasing part of vk+1(x), 
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After partial integration, 
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Using equidistant discretization, 
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 The elements of the stiffness matrix Lkj can be calculated in similar way after the 

derivation of the base function, 
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Hereafter the diagonal and the non-diagonal elements can be derived simply. Since M and L 

are tridiagonal matrices, the LAS can be solved effectively by e.g. LU decompositon, 

conjugate gradient or any specialized method. 

 

1.3 FDM vs FEM 
 

 Finite difference method (FDM) is a very popular method to solve differential 

equation. Owing to the simplicity of its programming, FDM is quite widespread, therefore it 

is worth making a qualitative comparison between FDM and FEM. 

 Probably, the most essential distinction between the two methods is that FDM 

approximates the PDE, while FEM approximates the solution of the PDE (Table 1.1). 

However, mathematically (incl. coding) FDM is much more simple than FEM which demands 

much deeper knowledge in numerical mathematics and programming. FDM can be effectively 

applied in regular/simple model geometry (rectangle, circle, block, sphere, cylinder etc.), 
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while FEM is very useful especially in complex model geometry. In FDM the solution is 

unknown between the grid points, while in FEM the solution among nodes can approximated 

by optional base functions. In general, it can be established that the accuracy of FEM solution 

exceeds the accuracy of FDM. 

 It is noted that the complexity of the applied base function can be enhanced, however 

it will increase the number of unknowns (degree of freedom) resulting in computations with 

longer CPU time, larger memory demand (larger size of M and L) and sometimes higher 

uncertainty. Additionally, adaptive mesh is able to estimate the accuracy of the solution 

through the propagation of error, and if it is necessary, the number of finite elements, the 

order of base functions can be modified during the solution process. It is called r adaptivity, 

when the mesh moves, which can be very useful e.g. in a fluid flowing in a pipe. It is called h 

adaptivity, when the resolution of FEM mesh is increased or decreased during the solution. 

Using p adaptivity, the order of the base function can be modified. Of course, the combination 

of the abovementioned adaptivities can be accomplished, e.g. hp adaptivity. 

 

FDM vs FEM 

Approximation of PDE < Approximation of the solution of PDE 

Mathematically simple > Mathematically complex 

Applicable in simple geometry < Applicable also in complex geometry 

Solution is not known between grids < 
Solution among nodes can be approximated 

by arbitrary base function 

Generally less accurate < Generally more accurate 

Table 1.1 Qualitative comparison between FDM and FEM 
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2 INTRODUCTION TO COMSOL MULTIPHYSICS 
 

 The handbook entitled Introduction to COMSOL Multiphysics recommends several 

examples which facilitate the users to deepen the knowledge of using the software package. In 

order to catch the conception of solving multiphysical problems (coupled PDEs), the example 

busbar (page 54) directs the reader from the model building to the visualization of the 

numerical solution. 

 

2.1 Physical description of electrical heating 
 

 The physical problem is well-known as the electrical heating or Joule heating which is 

called also the 1
st
 Law of James Prescott (1940). Direct current flowing through a conductor 

produces heat. As the temperature increases, the resistivity of the conductor enhances, which 

decreases the current density. Figure 2.1 illustrates qualitatively how the Laplace’s equation 

describing the electric potential variation is coupled with the heat transport equation through 

Joule heating. The heat produced by electric current modifies the temperature distribution, 

which alters the resistivity of the conductor. This clearly affects the potential distribution 

again. 

 Before taking up the numerical solution of the example, it is worth considering the 

physical determination of the given problem. The 2
nd

 Law of James Clerk Maxwell 

(Faraday’s Law) for stationary problem is 

 0





t

B
Erot , (2.1) 

where E and B denote the electric field and the magnetic flux density, while t is the time. Any 

non-rotational vector field can be generated as a gradient of a scalar field, that is 

 VgradE  , (2.2) 

V is the electric potential. 

 Second, the general Ohm’s Law serves for the current density j that 

 Ej  , (2.3) 

if convective current and the Lorentz’s motional electromagnetic field can be neglected, and 

here σ denotes electric conductivity of the medium. 

 Third, the charge conservation in stationary case results in 

 0jdiv  (2.4) 

without electric charge source. Assembling Eqs. (2.2)–(2.4) we get the Laplace’s equation for 

electric potential, 

 

Figure 2.1 Sketch of the coupling of the electrical heating problem. 

https://doc.comsol.com/5.3a/doc/com.comsol.help.comsol/IntroductionToCOMSOLMultiphysics.pdf
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   0 Vgraddiv  (2.5) 

in homogeneous and isotropic medium. 

 The heat transport equation in stationary problem without advection is 

   QTK graddiv , (2.6) 

where K and Q are the heat conductivity and the volumetric heat source, while T denotes the 

unknown temperature. The heat source in the right-hand side of Eq. (2.6) comes from 

electrical heating. The linearized Ohm’s Law says that the voltage is 

 IRU  , (2.7) 

where R and I are the resistance and the current. While the power of the direct current P is 

 
2IRIUP  . (2.8) 

Based on Eq. (2.8) the differential form of the volumetric heat Q obtained from the volumetric 

electric power is 

    222 1
VV

dv

dP
Q gradgradj 


 , (2.9) 

where ρ and v denote the electric resistivity and the volume as well as Eqs. (2.2) and (2.3) 

were used in Eq. (2.9). This is the coupling between the Laplace’s equation (Eq. (2.5)) and the 

heat transport equation (Eq. (2.6)). 

 Finally, we need to know the temperature-dependence of the electrical conductivity of 

the medium. For metals the conductivity decreases by increasing temperature, 

 
 )(1

1
)(

00 TT
T


 , (2.10) 

where ρ0 denotes the resistivity at temperature T0, while α is an appropriate constant. Eq. 

(2.10) gives the feedback between the heat transport equation and Laplace’s equation. Figure 

2.2 summarizes the quantitative relations of the system characterizing the physical problem of 

electric heating. 

 

  

 

Figure 2.2 Coupling between Laplace’s equation and heat transport equation describing the 

electrical heating problem 
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2.2 Example busbar as a multiphysical problem 
 

 Example busbar shows over how to compile a practical problem in COMSOL. The 

base task is the electrical heating in which parameter definition, building up model geometry, 

prescription of boundary and initial conditions, finite element mesh generation, solving PDE, 

visualization and interpretation of numerical results are presented. Additionally, the 

deformation of busbar due to heat expansion is calculated in order the multiphysical ability of 

the software to be highlighted. Finally, the busbar warmed by Joule’s heating is located in a 

wind channel to ensure the cooling of the tool by air advection. Let us start with the busbar 

example in the Introduction to COMSOL Multiphysics! 

 

https://doc.comsol.com/5.3a/doc/com.comsol.help.comsol/IntroductionToCOMSOLMultiphysics.pdf
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3 ELECTRIC CURRENTS 
 

 It will be shown in this chapter that it is really easy and fast to compile a numerical 

model which functions wrong and serves false results. I will point out the two typical errors in 

numerical modeling which entail incorrect solution. Then, the vertical electrical sounding 

(VES) as a fundamental geophysical survey method will be realized in COMSOL both along 

the horizontal surface and in a cave. 

 

3.1 Electric field of a point source 
 

 The very first step of a valid numerical model is the quantitative verification. Usually, 

it is a quite complex and time-consuming procedure, so here I am going only to flash the 

fundamentals of a typical testing process. It is clear, that our numerical results should be 

quantitatively compared with accepted analytical or numerical solutions. In the chapter of 

electric currents, the electric potential of a point current source in homogeneous and isotropic 

medium offers itself as a reference point. 

 The analytical solution of the above-mentioned problem is well-known from the 

course of Geoelectrical Methods. The potential of a point source in homogeneous and 

isotropic medium is 

 
r

I
rV

1

4
)(




 , (3.1) 

where V is the electric potential at a distance of r from the point source, I and ρ denote the 

current flowing out from the current source and the resistivity of the medium, respectively 

(Figure 3.1). Let us assume that the current is 1 A and the resistivity is 10 Ωm! In this case 

the potential at a distance of 1 m is 

 V795775.0
m1

1

4

m10A1
)m1( 




rV . (3.2) 

Let us build up a model and check the validity of the numerical solution! 

 To open the software package COMSOL Multiphysics, double-click the icon . 

After the program started, select Model wizard, then 3D to use three-dimensional model, 

open the AC/DC module for the given problem, choose Electric currents (ec) and press the 

button Add. We do not need any modules to build up a multiphysical problem, thus you can 

press Study. Here, you can choose the type of the study, which is Stationary in this case, 

then press Done to get the base desktop. 

 

Figure 3.1 Sketch of the electric point source 

problem. Current is represented by radial 

solid lines. Dashed lines denote the concentric 

equipotential surfaces. 

http://gali.web.elte.hu/assets/geoelektromos-kutat%c3%b3m%c3%b3dszer.pdf
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 First, the simple model geometry must be created. Press the right click on Geometry 1 

(Geometry 1_R) in the Model Builder and choose Sphere to get the homogeneous and 

isotropic model domain. The radius of the sphere is 100 m, which seems quite large to the 

effect of boundaries be negligible. In order to position the point source, right-click 

Geometry 1_R>More Primitives>Point. The coordinate of (0,0,0) is appropriate for the 

problem having spherical symmetry, so you can press Build All Objects in the Settings 

window to finalize the model geometry. If you would like also the interior of the solid 

domain, you can choose Wireframe Rendering in Graphics window (Figure 3.2). 

 You can check the applied equation to be solved by selecting the module Electric 

currents and opening Equation in Settings window. The equation of the stationary charge 

conservation with the source term (Eq. (2.4)), the reduced Ohm’s Law (Eq. (2.3)) and the 

definition of electric potential (Eq. (2.2) appear. To fill up the domain with ‘material’, click 

Current conservation 1, switch the Electrical conductivity in Settings to User defined, and 

type 1/10 S/m to get the resistivity of 10 Ωm as in the analytical example (Eq. (3.2)). Since 

the boundary of the models are far (r=100 m) from the point where the electric potential will 

be checked (r=1 m), therefore the outer boundary of the sphere can be considered grounded. 

To set up the boundary conditions Electric currents_R>Ground and select All boundaries 

in Boundary Selection. All the 8 spherical surface segments will be marked. If you open the 

menu Equation, you can see the quantitative boundary of V=0. Last, we need to assign the 

point source, Electric currents_R>Points>Point current source, then you should select the 

central point (#4) in Graphics window, and write Qj,p=1 A. 

 The most simple finite element mesh generation is if you right-click the Mesh, and 

select Build All. Messages below graphics window says, that the ‘complete mesh consists of 

8477 domain elements…’. To calculate the solution click simply Sudy 1 and Compute. 

 Electric potential in Results shows the calculated 3D potential field using a 

Multislice visualization method. In order to represent the current lines Results>Electric 

potential_R>Streamline. Select streamline Positioning>Start point controlled>Points: 

100, then press Plot. You can see that the current lines do not seem perfectly radial — 

especially in the surroundings of the point source —, as it would be required in homogeneous, 

isotropic medium (Figure 3.3). 

 As a next step, we will see the radial potential distribution near the point source. Click 

Results>Data sets_R>Cut Line 3D, then define the linear section by the two end points, 

 

Figure 3.2 Geometry of the electric point source model 



Numerical Modeling of Geophysical Problems 

15 
 

Point 1: 0.1, 0, 0 and Point 2: 3, 0, 0. It is suggested starting the section not from (0, 0, 0), 

where the potential tends to infinity. In addition, we need to insert a point, where the value of 

potential will be compared to the analytical solution, Results>Data sets_R>Cut Point 3D: 

(1, 0, 0). 

 Now, we should visualize the potential along the above-defined section, 

Results_R>1D Plot Group, and then 1D Plot Group_R>Line Graph. To select the defined 

line section, Line Graph>Data set: Cut Line 3D, and to select the defined point, 1D Plot 

Group_R>Point Graph>Data set: Cut Point 3D, then press Plot. You can see that the 

potential decreases approx. linearly from the point source, although it should follow the ratio 

1/r in Eq. (3.1). Let us check the quantitative values of the potential! Results>Derived 

values_R>Point evaluation>Data set: Cut Point 3D. Fill in the table, Expression: V, then 

press TAB to see the unit (V) and the description (Electric potential). Press the button 

Evaluate! In the Table 1 window (below the Graphics), the potential in the cut point appears: 

0.349935 V. This numerical solution really differs from the analytical solution (Eq. (3.2)). 

What is the problem with our numerical solution? 

 One typical problem is the mesh with low resolution. To handle this trouble, we 

should go back to Mesh and select Element size: Fine instead of Normal, then press Build 

All. You get 17211 finite elements discretizing the model (see Messages). Now, you can solve 

the problem, Study 1_R>Compute and go to Results>1D Plot Group to check the potential 

variation. The solution is rather linear again than 1/r  To check the potential value 1 m far 

from the point source, Results>Derived Values>Point Evaluation press Evaluate, the 

solution with finer mesh gives 0.456742 V, which is a bit better, but the deviation from the 

analytical value is really large. How can we increase the accuracy of the numerical solution? 

 It is a useful realization that mesh refinements should be done in the surroundings the 

point source, where the potential variation is high. In order to interfere with the mesh 

generation click Mesh_R>Size, then Size 1>Geometric Entity Level>Point and select the 

point number 4, as the point source. If you cannot see the inner point, you can deselect Mesh 

Rendering and select Wireframe Rendering. Click the Custom, and set the Maximum 

 

Figure 3.3 Inaccurate numerical solution of the electric potential and the current lines for the 

point source problem. 
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Element Size to 0.02 m. Now, you need to define the discretization method, Mesh_R>Free 

Tetrahedral. Press Build All, and you will see that 26396 finite elements were used for the 

new discretization, Study>Compute. Streamlines are much more linear in Graphics window, 

and the potential variation decreases following the ratio 1/r from the point source 

(Results>1D Plot Group). The evaluated electric potential 1 m far from the point source is 

0.787384 V (Results>Derived Values>Point Evaluation>Evaluate). The numerical solution 

agrees quite well with the analytical one, but COMSOL Multiphysics should yield much more 

accurate solution. 

 It is worth refining the meshing also in the neighborhood of the point, where we look 

for the potential value. To do this, we need to go back to Geometry_R>More 

Primitives>Point with a coordinate 1, 0, 0 and Build All Objects. To actualize the mesh near 

the new point, Mesh>Size 1 and select the point #7 from the Graphics window. Set the 

Size>Finer instead of Fine, and select Custom>Maximum element growth rate: 1.3. So, 

you control that the size of the neighboring elements can increase less than 30% in the whole 

domain. Press Buid All to get 91916 elements in discretization. Then Study>Compute. You 

can see that the streamlines are radial, and the potential decreases following the analytical 

solution. The numerical solution 1 m far from the point source is 0.787723 V, which is only a 

bit better than the former solution. It seems that refining the mesh does not reduce the 

deviation between the numerical and the analytical solution. How can we lessen the 

difference? 

 Another typical problem, which appears in the verification process, is the 

inappropriate boundary condition. In the analytical solution the ‘outer boundary’ is in the 

infinity, where the potential is zero. Although the numerical model is quite large-sized (outer 

boundaries are farther from the point source by 2 orders of magnitude than the evaluated 

point), but the boundaries are not in the infinity which might result in approx. 1% deviation in 

the numerical solution. We can check the effect of the boundary conditions, if we change 

them. Fortunately, the analytical solution is known, and the equipotential surfaces are 

spherical. Thus, the exact boundary condition can be described along the outer boundaries, 

Electric currents_R>Electric potential, select All boundaries from Selection box (#1–8), 

and define the Electric potential: 10/(4*pi*100) as it is prescribed in the example. 

Study>Compute. Figure 3.4a illustrate the numerical solution of the 3D potential field with 

radial streamlines, and Figure 3.4b shows the potential variation between x=0.1–3 m. It is 

suggested graphing the potential as a function of x, Results>Electric Potential>Line 

Graph>Parameter>Expression: x, instead of Arc Length. The evaluated electric potential in 

the observed point is 0.795680 V, which is acceptable in this simple numerical verification 

 

Figure 3.4 Verified numerical solution of the electric point source problem in homogeneous and 

isotropic medium. (a) Electric potential field and current lines, (b) Radial electric potential profile. 
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process. We should not forget saving the model, e.g. Save>Point source. In summary, we can 

conclude that it is very simple to build up a numerical model serving solution, but the 

validation of the model and the verification of the numerical solution are much more difficult 

and time-consuming task. 

 

3.2 Point source in heterogeneous medium 
 

 In order to accentuate the advantage of the finite element numerical method, we 

present a model of which does not have analytical solution. Continuing the former model, an 

ellipsoid will be inserted into the homogeneous medium. To modify the geometry, 

Geometry_R>More Primitives>Ellipsoid>Semiaxis: 3, 1, 1 and Position: 5, 0, 0, then 

Build All Objects. Since this object has different domain parameter, we need insert a new 

Electric currents sub-module from the first track of Electric currents_R>Current 

Conservation. Click the ellipsoid in Graphics window by scrolling the mouse, and #2 will 

appear in the Selection box. This object will be a bad electric conductor, so Electric 

conductivity>User defined: 1/1000 S/m. Because we do not already need the Ground 

boundary condition, we should delete it. From this moment all of boundary condition (#1–16) 

are reset to Electric potential defined above. Of course, the electric potential must be 

prescribed only on the outer boundary conditions (#1–8), thus surfaces of #9–16 need to be 

removed (- sign) from the Selection box. 

 After modifying the geometry, the mesh must be adjusted as well, Mesh_R>Size, then 

Size 2>Geometric entity level (GEL)>Domain, and select ellipsoid (#2), 

Custom>Maximum element size (MES): 0.5 m, to maximize the size of the finite elements 

as 0.5 m. Buttons of Wireframe Rendering, Transparency, Zoom In/Out/Box, Zoom Extents 

and Go to Default View in Graphics window facilitate the navigation in a complex geometry. 

We need to move the Size 2 menu above Free Tetrahedral to specialize the discretization 

method, and Build All. The mesh consists of 102,493 finite elements, Study>Compute. 

 After solving the problem, the selection of the appropriate visualization method is very 

important. To display the electric potential on the surface of the ellipsoid, we need to define 

the surface first, Results>Data Sets_R>Surface: #9–16 in the Selection box. You can rotate 

the model in Graphics window, when you are moving the mouse while the left button is being 

pressed. You can move the model in Graphics window with the right button. To go back to 

 

Figure 3.5 Electric potential on the surface of the high-resistivity ellipsoid, and current lines 

(red). 
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the normal view, just press Go to Default View. The electric potential on the surface of the 

ellipsoid can be visualized, Results>Electric Potential_R>Surface>Data Set: Surface 1, it 

is useful to remove the potential slices, Results>Electric potential>Multisclice_R>Disable. 

Zooming in the solution, the quasi-radial current lines try to avoid the high-resistivity 

ellipsoid (Figure 3.5). It is clear that the potential on the ellipsoid surface is higher near the 

point source. 

 As a check test, a low-resistivity object can be positioned in the model in symmetric 

manner. Turning back to the Geometry_R>More Primitives>Ellipsoid>Semiaxis: 3, 1, 1 

and Position: -5, 0, 0, then Build All Objects. To fill up the new domain, Electric 

currents_R>Current Conservation. Select the left ellipsoid in Current Conservation 3. 

Take care of that the numbering of the domains has already changed due the modification in 

the geometry! Click the new/left ellipsoid (#2) to appear in the Selection box, and specialize 

its conductivity, Electric conductivity>User defined: 1/0.1 S/m, to get an object with low 

resistivity of 0.1 Ωm. Then select #2 in Mesh>Size 2 and Build All the mesh (#113,062), 

Study>Compute. 

 If you want to visualize the potential of both ellipsoid surfaces, you need to modify 

Results>Data Sets>Surface 1 including #5–12 and #17–24. Now you can see the numerical 

solution of the inhomogeneous problem, as the current lines are attracted by the low-

resistivity ellipsoid (Figure 3.6). It seems that there is no relevant potential difference within 

this object. 

 Finally, we can quantify the solution along a section through these objects. Let us 

modify the former cut line, Results>Cut Line 3D from (1,0,0) to (9,0,0), and create a new 

one, Results>Data Sets>Cut Line 3D 1_R>Duplicate, then define Results>Data Sets>Cut 

Line 3D 2 from (-9,0,0) to (1,0,0). If you press the button Plot, you can see the Cut Line 3D 1 

to intersect the low-resistivity ellipsoid. You can duplicate the graph by Results>1D Plot 

Group>Line Graph 1_R>Duplicate, and switching in Line Graph 2>Data set to Cut Line 

3D 2. Line graph illustrates the nonsymmetrical potential distribution around the point source 

in non-homogeneous medium. Do not forget to save the model as Save as>Point source in 

heterogeneous medium. 

  

 

Figure 3.6. Electric potential on the surface of the low-resistivity (left) and the high-resistivity 

(right) ellipsoid, and current lines (red). 
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3.3 Vertical electrical sounding 
 

 In this chapter a simple numerical model of the vertical electrical sounding (VES) will 

be built up, which is one of the most popular geophysical survey method and it is used to 

reveal the resistivity distribution of the subsurface. Model Wizard>3D>AC/DC>Electric 

Currents>Add, then Sudy>Stationary>Done. 

 The subsurface is represented by a block, Geometry_R>Block with a Width: 1000 m, 

Depth: 1000 m and Height: 500 m using a Base position of (-500,-500,-500) m. The four 

pointwise electrodes are positioned on the surface, Geometry_R>More Primitives>Point 

with a position of (-4,0,0) m, and Geometry_R>More Primitives>Point with a position of 

(-1,0,0) m. The VES arrangement is symmetrical, so you can duplicate them, select Point 1 

and 2_R>Duplicate to (1,0,0) m and (4,0,0) m and Build All Objects. The four current and 

potential electrodes are aligned on the surface. 

 As a second step, we need to define the properties of the medium including the 

boundary conditions. Our model includes only one domain, Electric currents>Current 

Conservation 1>Electrical conductivity>User defined: 1/10 S/m having a resistivity of 

10 Ωm. Let us give the boundary conditions, the side walls and the bottom of the model are 

far from the current sources, Electric currents_R>Ground>Selection: All boundaries 

without the surface of #4, which is considered as an insulating boundary due to the high 

resistivity of the air. When the surface #4 is removed from the Selection box in Ground, you 

can see its appearance in the Selection box of Electric insulation, which is the default 

boundary condition in this module. All of other boundaries are overridden by Ground 

boundary condition. Current electrode A will be the left point, Electric 

currents_R>Points>Point Current Source, after selection the left pointwise electrode (#5), 

you need to define the Point current source>Qj,p: 0.1 A. To set the current electrode B, 

Point Current Source 1_R>Duplicate, then remove #5 from the Selection box of Point 

Current Source 2 and insert the right electrode, #8. Do not forget modifying the Point 

current source of the return electrode to Qj,p:-0.1 A. 

 Finite element mesh needs to ensure better refinement near the point electrodes, 

Mesh_R>Size, then Size>Custom>MEGR: 1.3 to decrease the variability of the element size 

in the whole domain. Size 1>GEL>Point: #5–8 (electrodes), Custom>MES: 0.2 m. We have 

to select the discretization method, Mesh_R>Free Tetrahedral and Build All resulting in 

29656 finite elements, Study>Compute. 

 Multislices do not show any variation in electric potential, since it is zero in the mid-

plane between A and B, and it tends to infinity crossing the pointwise current electrodes. 

Therefore, it is worth modifying the position of the planes, Results>Electric 

Potential>Multislice>Multiplane Data>X-planes>Entry method>Coordinates: 

-100 100 m, while in Y- and X-planes>Planes: 0. It is instructive to display the current lines, 

Results>Electric Potential_R>Streamline, which shows the streamlines of the current 

density vector in Expression box: ec.Jx, ec.Jy and ec.Jz, where ec refers to the name of the 

module: Electric currents. Select Streamline Positioning>Magnitude controlled to the 

streamline be denser, where the current density is higher. Figure 3.7 illustrate the current lines 

between the current electrodes, and the two vertical planes display the potential distribution 

on the side of electrode A (positive) and return electrode B (negative). 

 A possible verification method is, when the apparent resistivity computed from the 

electrode potential gives back the resistivity of 10 Ωm defined earlier. Results>Derived 

Values_R>Point Evaluation, select the inner electrodes (#6 and 7) as potential electrodes M 

and N, Expression: V and Evaluate. Table 1 serves the two potential values on electrode M 

and N, VM=0.0212180 V and VN=-0.212183 V, the symmetry is not perfect owing to the non-



Electric Currents 

20 
 

exact numerical solution. Based on the knowledge in the course of Geoelectrical Methods, the 

apparent resistivity ρa can be calculated, 
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where K, ΔV and I are the geometrical coefficient of the electrode arrangement, the potential 

difference between the potential electrodes and the current flowing out of the current 

electrode A, respectively, while rXY denotes the distance between electrode X and Y. Using 

the symmetry of the arrangement, that is rAM=rBN and rAN=rBM, 
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Substituting the computed and defined values, 

 m999.9
A1.0

V0212183.0V0212180.0

m5

1

m3

1







a , (3.5) 

which shows a quite good agreement with the given resistivity value of 10 Ωm. It is 

unfortunate, that there is no chance to get such an accurate result in the field. 

 There might be a second test, if we study, how varies the calculated apparent 

resistivity above the homogenous subsurface depending on the current electrode distance, rAB. 

First, let us move the current electrode from the central point, Geometry>Point 1>x: -16 m, 

and Geometry>Point 4>x: 16 m, Build All Objects. Regenerate the mesh for the new 

geometry, Mesh_R>Build All resulting in 53529 elements, Study>Compute. 

 We can repeat the above calculation, Results>Derived Values>Point 

Evaluation>Evaluate, the electric potential on the potential electrodes is VM=0.00124867 V 

and VN=-0.00124773 V. It gives for the apparent resistivity, 

 

Figure 3.7 Numerical solution of the electric potential on two vertical slices and the current lines 

(red) in a given VES arrangement. 

http://gali.web.elte.hu/assets/geoelektromos-kutat%c3%b3m%c3%b3dszer.pdf
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Accordingly, increasing the current electrode distance rAB, that is the penetration depth of the 

VES arrangement does not modify the value of apparent resistivity above homogeneous 

subsurface. Save the COMSOL model as VES in homogeneous medium. 

 How does the implication of a deep, high-resistivity layer influence the apparent 

resistivity? We create the shallow layer, Geometry_R>Block with a Width: 1000 m, Depth: 

1000 m and Height: 10 m using a Base position of (-500,-500,-10) m and Build All. Let the 

resistivity of the lower layer be 100 Ωm, Electric Currents>Current 

conservation 1_R>Duplicate, Electric Currents>Current conservation 2, remove the 

upper layer (#2), and modify Electrical conductivity>User defined: 1/100 S/m. 

Mesh_R>Build All results in 112,971 finite elements, Study>Compute. 

 We expect that the apparent resistivity obtained from electrode potentials gives a value 

between the resistivity of the upper (10 Ωm) and the lower (100 Ωm) layer. Results>Derived 

Values>Point Evaluation>Evaluate, VM=0.00186768 V and VN=-0.00186785 V. Thus the 

‘measured’ apparent resistivity, 
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which serves an intermediate value. 

 Finally, we show, how the current density varies in the mid-plane, Results>Electric 

potential>Multislice>Multiplane Data>X-plane>Coordinates: 0 m, as well as 

Expression>Replace Expression>Component 1>Electric Currents>Currents and 

charge>Current density norm (ec.normJ) in unit A/m
2
 and Plot. If you change the 

streamline method, Results>Electric Potential>Streamline>Streamline Positioning>Start 

point controlled>Number of points>Points: 100, and refine the streamlines 

Quality>Resolution>Finer, you will realize the enhanced current density in the upper, low-

resistivity layer after zooming in the model (Figure 3.8). Save>VES in heterogeneous 

medium. 

 

Figure 3.8 Normal (horizontal) current density distribution in the midplane and the current 

lines (red) in the two-layer VES model. 
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3.4 VES in a cave 
 

 In this last part, I would like to draw attention to the importance of the geometry of the 

medium. VES model is valid only for measuring above horizontally layered homogeneous 

and isotropic medium by point-wise electrodes, although filed-site circumstances are never in 

perfect accordance with the theoretical models. Nevertheless, the analytical solutions have to 

be re-interpreted in several geological situations, e.g. in case of VES measurements completed 

in cave. 

 Model Wizard>3D>AC/DC>Electric Currents>Add, then Study>Stationary> 

Done. VES measurement is accomplished in a cave bored in granite formation, so the rock 

and the cave are represented by a cylinder, Geometry_R>Cylinder with a Radius: 200 m 

and Height: 1000 m positioned at x=-500 m and y=z=0. The axis of the cylinder should be 

parallel to x, Axis>Axis type: x-axis. To create the cave, Geometry>Cylinder 1_R> 

Duplicate and modify the Cylinder 2>Radius: 3 m, Build All Objects. We need to crop the 

cave from the rock, Geometry_R>Booleans and Partitions>Difference, click the formation 

(cyl1) to add to Objects to add box, then click the cave (cyl2) to add to Objects to subtract 

box, and press Build All Objects. If you press the button Go to YZ View, you can see 

through the model along the cave. Let us locate the electrodes on the side walls of the cave, 

Geometry_R>More Primitives>Point at x=-1 m, y=-3 m and z=0. Duplicate the first 

electrode, Geomtery_R>Point 1 to Point 2>x=-0.5 m. Then Duplicate Point 2 to 

Point 3>x=0.5 m, and duplicate Point 3 to Point 4>x=1 m. Build All Objects, Go to 

Default View and press Wireframe Rendering to see into the model geometry. 

 Set the resistivity of the homogeneous rock of 1000 Ωm, Electric Currents>Current 

Conservation 1>Electrical conductivity>User defined: 1/1000 Ωm. The boundary of the 

rock and the cave is electrically insulated as the default boundary condition, but other 

boundary should be grounded, Electric Currents>Ground adding the outer boundaries of 

#1, 2, 3, 6, 9, 10 to Selection box. Now, we need to define the current flowing out of 

electrodes, Electric Currents_R>Points>Point Current Source, then click the left electrode 

to be A (#9), and set Qj,p: 0.1 A. To set also the return electrode B, Electric Currents>Point 

Current Source 1_R>Duplicate, and remove #9 from Selection box and add the right 

electrode (#12) in Point Current Source 2, then type the Point current source> Qj,p: -0.1 A. 

 We need to refine the mesh near the electrodes, Mesh_R>Size, decrease the element 

growth, Size>Custom>MEGR: 1.3, and Size 1>GEL>Point: #9–12, and set Custom>MES: 

0.1 m. For discretization we can use Mesh_R>Free Tetrahedral and Build All, which 

generates 48475 finite elements. If you would like to check the refined meshing in the 

surroundings of the electrodes, press the button Click and Hide in Graphics window, select 

the outer cylinder surface and use Zoom Box. Solve the problem by Study>Compute. 

 In order to visualize the current density in the mid-plane, Results>Electric 

Potential>Multislice>Multiplane Data>X-planes>Coordinates: 0 m, and Number of 

planes: 0 in Y- and Z-planes. You should select Expression>Replace 

Expression>Component 1>Electric currents>Currents and charge>Current density 

norm (ec.normJ). Let us display the current lines, Results>Electric 

Potential_R>Streamline>Streamline Positioning>Start point controlled>Points: 50, and 

press the button Plot. If you zoom in the electrodes, you can see the higher current density 

behind the wall of the cave, as a half-space model (Figure 3.9). 

 To calculate the apparent resistivity, we can repeat the method presented in part 3.3, 

Results>Derived Values_R>Point Evaluation, add electrodes M and N (inner electrodes) to 

the Selection box by clicking #10, 11, then Expression: V and Evaluate. The potential on 

potential electrodes is VM=19.9421 V and VN=-19.9304 V, which gives the value of 
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for the apparent resistivity. It seems too low relative to the rock resistivity of 1000 Ωm 

defined earlier. 

 Increasing the current electrode distance rAB, i.e. deepening the penetration of VES, we 

can investigate the variation of the apparent resistivity. Let us move A and B farther from the 

central point, Geometry>Point 1>x: -30 m and Geometry>Point 4>x: 30 m, Build All 

Objects. Regenerating the mesh, Mesh>Build All results in 83388 elements, then 

Solve>Compute. 

 Results>Electric Potential shows that current is able to encompass the cave (Figure 

3.10). We can compute the apparent resistivity again, Results>Derived Values>Point 

Evaluation>Evaluate. The potential electrodes give VM=0.00904019 V and VN=--

0.00917432 V, thus the apparent resistivity is 
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For the first though, it is surprising, since the granite formation is homogeneous. However, if 

we remember the VES model, we can realize that it has already not been valid for this case, 

because the surface is not horizontal. To conclude, as the distance rAB increases, the 

penetration deepens and the applied half-space model becomes rather a complete space 

model. It is reflected in the solution of the apparent resistivity, ρa≈1000 Ωm for near current 

 

Figure 3.9 Current density field in the midplane of near current electrodes (rAB=2 m). Current 

lines are denoted by red lines. 
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electrodes decreases continuously to ρa≈500 Ωm for far current electrodes. It could be 

corrected by a gradually increasing geometry coefficient from 
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however the rate of the growth is not trivial. One solution might be the numerical modeling to 

determine the correct growth rate. Please, don not forget saving the model, Save>VES in 

cave. 

 

 

Figure 3.10 Current density field in the midplane of far current electrodes (rAB=60 m). Current 

lines are denoted by red lines. 
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4 MAGNETIC FIELD 
 

 In this chapter, we shall compile a simple numerical model which reflects the 

stationary magnetic dipole field of the Earth using an axial and central elementary magnetic 

dipole approximation. Second, a typical magnetic field survey will be presented above buried 

iron objects, then, such a model will be built up, which is not a typical geophysical task. 

 

4.1 Magnetic dipole field of the Earth 
 

 Model Wizard>3D>AC/DC>Magnetic Fields>Add, then press Study>Stationary> 

Done to start the necessary module. It is useful to learn how parameters can be defined in a 

COMSOL model. Global Definitions>Parameters, and no we need to fill in the table as in 

Table 4.1. The third column is filled up automatically in the software. 

 

Name Expression Value Description 

Rf 6.37e6 [m] 6.37E6 m Earth radius 

md 7.768e22 [A*m^2] 7.768E22 m
2
∙A Magnetic dipole momentum 

Table 4.1 Parameters defined for the Earth’s magnetic field 

 

 Next step is creating the geometry, Geometry_R>More Primitives>Point, which 

denotes the position of the elementary magnetic dipole. The Earth and the magnetosphere will 

be approximated by spheres, Geometry_R>Sphere>Radius: Rf, the radius of the 

magnetosphere is five times larger than that of the Earth, Geometry>Sphere 1_R>Duplicate, 

and Sphere 2>Radius: 5*Rf, and press Build All Objects, then Zoom Extents and 

Wireframe Rendering to look into your model. 

 Now, we need to fill up the model with physics in Magnetic Fields row. You can 

check the Equation, which is solved by COMSOL, this is the first law of Maxwell in 

stationary state (Ampère’s Law), the definition of vector potential and the Ohm’s Law with 

conductive and external current. Let us set the elementary magnetic dipole in the origin, 

 

Figure 4.1 Central and axial magnetic dipole field of the Earth illustrated by the direction 

(normalized red arrows) and the magnitude of the magnetic flux density (two sections). 
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Magnetic Fields_R>Points>Magnetic Point Dipole and add #7 (origin) to the Selection 

box. We should define the direction and the magnitude of the point dipole, Magnetic dipole 

momentum direction>z: -1 and Magnetic dipole moment, magnitude: md. In the 

Magnetic Fields>Ampère’s Law the Relative permeability, the Electrical conductivity 

and the Relative permittivity should be set to User defined (μr=1, σ=0, εr=1), which are 

unimportant in calculating the magnetic field. 

 Last step before the solution is the mesh generation, Mesh_R>Size, and Size 1>GEL: 

Boundary: #5–8, 11, 12, 14, 15 (the Earth’s surface), you can use the scroll of the mouse to 

enter the interior of the model, and left button to rotate it. To refine the discretization, 

Custom>MES: Rf/10. In order to increase the resolution in the surroundings of the magnetic 

source, Mesh_R>Size, and Size 2>GEL>Point: #7, Custom>MES: Rf/100. We should not 

forget the method of the discretization, Mesh_R>Free Tetrahedral and Build All to get 

54201 finite elements, then press Study>Compute. In the Progress menu you can see that 

the software chooses an iteration method FGMRES to solve the problem, the iteration can be 

followed in the Convergence Plot. 

 Visualizing the solution Results>Magnetic Flux Density Norm>Multislice>Y-

Planes: 0, while X-Planes>Entry method>Coordinates: 1e6 m and Z-Planes>Entry 

method>Coordinates: -1e6 m. To see the direction of the magnetic field, Results>Magnetic 

Flux Density Norm_R>Arrow Volume>Entry method>Number of points: 10 in all 

directions. The length of the arrows should be Arrow length>Normalized to show only the 

direction of the field without the magnitude. Figure 4.1 illustrates the simplified magnetic 

field of the Earth by two sections and the direction pointing from the geographic south to 

north. 

 Finally, it is worth quantitatively checking also the magnitude of the magnetic field, 

Results_R>1D Plot Group, and 1D Plot Group_R>Line Graph, then sections #6, 7 (a line 

of longitude on the Earth’s surface) should be added to Selection box. We should use Unit: 

nT, and press Plot. Figure 4.2 shows that the magnitude of the total magnetic flux has a 

maximum on the poles (60000 nT), and it has a minimum at the magnetic equator (30000 nT). 

We can visualize also the components of the magnetic flied separately, Line Graph>y-Axis 

Data>Replace Expression>Component 1>Magnetic Fields>Magnetic>Magnetic Flux 

Density: mf.Bx - Magnetic Flux Density, x component and Plot. As you can see, there is no 

 

Figure 4.2 Magnitude of the magnetic flux density along a longitude from the south to the north 

pole of the Earth. 
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x component at the poles and the equator, and it has a minimum (-45000 nT) and a maximum 

(45000 nT) between those. To display the y component, rewrite Expression: mf.By, and press 

Plot, where mf is the abbreviation of the name of the module, Magnetic Fields. You can see a 

random variation between -20 and 200 nT, which is the numerical error of the solution, since 

along the given section the y component of the magnetic field should be zero. The vertical 

component of the magnetic field (in COMSOL coordinate!!), Expression: mf.Bz, and Plot, 

shows that the magnetic flux density points ‘downwards’ at the poles and ‘upwards’ at the 

equator. The latter explains, that here the magnetic field does not have x, y components. You 

should save the model, e.g. Save>Earth’s magnetic field. 

 

4.2 Buried objects 
4.2.1 Iron barrels 

 

 Searching buried objects using non-invasive method is a typical task of the exploration 

geophysics. If the buried object has an induced or remanent magnetic field, magnetic 

exploration is an effective method to reveal the spatial position of the objects. In this example 

the magnetic anomalies induced by subsurface iron barrels and pipes will be computed. 

 As a first step, we need to choose the appropriate module, Model Wizard>3D> 

AC/DC>Magnetic Fields, No Currents (mfnc)>Add, then Study>Stationary>Done. The 

air above the surface is Geometry_R>Block with Width: 100 m, Depth: 50 m and Height: 

10 m. To get the subsurface, Geometry>Block_R>Duplicate and set Block 2>Position>z: 

-10 m, then Build All Objects. The surface is the internal boundary at z=0. Let us build into 

the model four buried barrels with different parameters, Geometry_R>Cylinder>Radius: 

0.5 m to the Position>x: 10 m, y: 10 m and z: -2 m, which is 1 m beneath the surface. To get 

the 2
nd

 barrel, Geometry>Cylinder 1_R>Duplicate, and modify Height: 2 m, x: 20 m and z: 

-3 m. The 3
rd

 barrel, Geometry>Cylinder 2_R>Duplicate, and modify Height: 1 m, x: 30 m. 

And the last one, Geometry>Cylinder 3_R>Duplicate, and modify Radius: 1 m, Height: 

1 m, x: 40 m. Press Build All Objects and Wireframe Rendering to see as the objects with 

different height, radius or depth are aligned parallel with the axis x. In order to be able to 

refine the mesh direct above the barrels, we need to insert four points, Geometry_R>More 

Primitives>Point: (10, 10, 0) m, the other three points should be created by duplication to the 

 

Figure 4.3 Geometry of the model including the air, the subsurface and the four buried iron 

barrels. 
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given position, Point 2: (20, 10, 0) m, Point 3: (30, 10, 0) m and Point 4: (40, 10, 0) m, and 

Build All Objects. Figure 4.3 shows the model geometry. 

 The equations solved in module Magnetic Fields, No Currents>Magnetic Flux 

Conservation>Equations are shown as the 1
st
 Maxwell’s Law without currents, the relation 

between the magnetic flux density and the magnetic field as well as the definition of the 

magnetic potential. Set the Relative permeability>μr>User defined: 1 for the air and the 

ground, while Magnetic Fields, No Currents_R>Magnetic Flux Conservation>Relative 

permeability>μr>User defined: 1000 for the iron barrels (#3–6). For the configuration of the 

appropriate boundary condition, we need to take a little loop-way. 

 The magnitude of the total magnetic flux density in Hungary is approx. T=48700 nT, 

the inclination is about I=65º, while the declination is D=2º. Figure 4.4 illustrate the above-

mentioned parameters, the horizontal (H) and the vertical (Z) components of the magnetic 

field in a local coordinate system, where X and Y point to the geographical north and east, 

while Z shows downwards. The vertical, 

 nT44140sin  ITZ , (4.1) 

and the horizontal components, 

 nT20580cos  ITH  (4.2) 

are calculated based on the Fig. 4.4, while the northern and the eastern components of the 

horizontal magnetic field are 

 nT720sinandnT20570cos  DHYDHX , (4.3) 

respectively. These values of the magnetic flux density will be given as outer boundary 

conditions, but we need to reconcile the coordinate system used in COMSOL and used in 

magnetic exploration presented in Fig. 4.4. In COMSOL x points to the east (Y), y points to 

the north (X) and z points upwards (-Z). Thus the boundary conditions specified in COMSOL 

are Magnetic Fields, No Currents_R>Magnetic Flux Density>Type: Magnetic Flux 

Density>x: 720 nT, y: 20570 nT and z: -44110 nT, and to add All boundaries to Selection 

box. I note that this boundary condition is not applicable to the inner boundary, the surface 

(#6). 

 The mesh is suggested refining within the barrels, Mesh_R>Size, then 

Size 1>GEL>Domain: #3–6 (barrels), Custom>MES: 0.2 m, and on the surface above the 

barrels, Mesh_R>Size, then Size 2>GEL>Point: #11, 20, 29, 38, Mesh_R>Size, 

Custom>MES: 0.2 m. The discretization is made by Mesh_R>Free Tetrahedral, resulting 

49208 finite elements after Build All. If one would like to look into the interior parts of the 

 

 
Figure 4.4 Local coordinate system of the 

magnetic field. 
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meshed model, in Graphics window press Select Boundaries, Click and Hide, then choose 

the upper and the lower boundary of the model. After rotating your model, you can see the 

finer mesh on the surface of the barrels. You can go back by clicking Go To Default View. 

Solve the problem by Study>Compute. The iterative Conjugate gradients method is chosen 

by COMSOL as you can see in Convergence Plot of Graphics window. After 22 steps the 

iteration reached the predefined threshold for the error, 10
-3

. 

 Let us see the computed magnetic flux density on the surface, Results>Magnetic Flux 

Density Norm>Multislice>Multiplane Data>X-planes: 0 and Y-planes: 0, while Z-

planes>Coordinates: 0 m, then press Plot. The value of B varies between 48000 and 

60000 nT, Unit: nT. These extreme anomalies on the surface appear owing to that the barrels 

are thought to be compact iron. One can see that the maximum magnetic anomaly is observed 

above the 2
nd

 barrel, because it is higher (2 m) than the other barrels, and it is situated 

shallower than barrel 3 and 4. We can easily investigate how the magnetic field varies 

upwards. At z=1 m, Multiplane Data>Z-planes>Coordinates: 1 m, the value of the 

magnetic flux density ranges between 48500 and 51500 nT. At z=2 m, Multiplane Data>Z-

planes>Coordinates: 2 m, the value of the magnetic flux density ranges between 48600 and 

49900 nT. At z=3 m, Multiplane Data>Z-planes>Coordinates: 3 m, the value of the 

magnetic flux density ranges between 48600 and 49300 nT. It is clear that the horizontal 

extension of the magnetic anomalies increases, while the amplitude of those decreases. We 

can continue the investigation downwards, too, as a downward continuation, at Z-

planes>Coordinates: -0.2 m, or at Z-planes>Coordinates: -0.5 m. The conclusion is 

obvious, the extension of the anomalies decreases, while the amplitude of the anomalies 

increases. Looking the surface magnetic field from above, Z-planes>Coordinates: 0 m, and 

click Go To XY View, a minor negative anomaly appears north to the main positive 

anomalies. If we visualize the x component of the magnetic field, Replace 

Expression>Component 1>Magnetic Fields, No Currents>Magnetic>Magnetic Flux 

Density>mfnc.Bx - Magnetic flux density, x component, a positive and a negative anomaly 

appear on the left-side and on the right-side of the barrels, respectively. Changing 

Expression: mfnc.By, a positive and a negative anomaly appear south and north of the 

barrels, resp. In order to explain the phenomenon, click Go To Default View and visualize 

also the streamlines of the magnetic field, Magnetic Flux Density 

Norm_R>Streamline>Streamline Positioning>Start Point controlled>Number of Points: 

100. After rotating and zooming in the solution, you can see that the magnetic flux lines are 

attracted by the barrels having high relative magnetic permeability (μr=1000) and resulting in 

negative/positive anomalies north and east/south and west of the barrels (Figure 4.5a). The 

total magnetic field can be presented along a section above the barrels, Data Sets_R>Cut 

Line 3D>Point 1: (0, 10, 0) to Point 2: (80, 10, 0), then Results_R>1D Plot Group, 1D Plot 

Group_R>Line Graph>Data Sets>Cut Line 3D 1, Expression>Replace Expression> 

 

Figure 4.5 (a) y component of the magnetic flux density on the surface and the flux lines of the 

magnetic field (red). (b) Magnitude of the magnetic flux density on the surface above the buried 

barrels. 
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Component 1>Magnetic Fields, No Currents>Magnetic>mfnc.normB - Magnetic flux 

density norm using Unit: nT. Although the resolution of the solution is not satisfied for a 

quantitative solution, it is clear that the 2
nd

 barrel produces the highest (~9000 nT), while the 

3
rd

 barrel generates the lowest (~1000 nT) magnetic flux density anomaly (Figure 4.5b). It is 

worth saving the model, Save>Buried objects 1. 

 

4.2.2 Iron pipe in W-E direction 

 

 A buried iron pipe results in different magnetic anomaly on the surface, 

Geometry_R>Cylinder>Radius: 0.5 m, Height: 30 m, and Position: (10, 30, -1.5) m, 

Axis>Axis type: x-axis, then click Build All Objects. Here the axis of the pipe is situated at 

a depth of 1.5 m being parallel to axis x, and its diameter is 1 m. Add pipe to the Selection 

box of Magnetic Flux Conservation 2: #3–7, and also to the finer mesh, Mesh>Size 1: #3–

7, then regenerate the mesh, Build All (#162 144), Study>Compute. 

 If you go to Results>Magnetic Flux Density Norm>Multisclice>Go To XY View, 

an asymmetry appears in the case of the pipe. It is more eye-catching, if you clear away the 

flux lines, Results>Magnetic Flux Density Norm>Streamline_R>Disable. The y 

component of B (mfnc.By) decreases from west to east due to the deviation between the 

magnetic and the geographic north directions (D=2º). (You can check it, if you set the x 

component of the magnetic flux density from 720 nT to 0 at the boundary condition.) You 

should save this model, e.g. Save As>Buried Objects 2. 

 

4.2.3 Iron pipe in N-S direction 

 

 By a last modification of this example, we can study how alters the solution if the iron 

pipe is quasi-parallel to the horizontal component of the magnetic field. Locate a new pipe in 

the model, Geometry>Cylinder 5_R>Duplicate>Position: (60, 10, -1.5) m and Axis type: 

y-axis, then Build All Objects. We need to add this new pipe to the Selection box in both 

Magnetic Fields, No Currents>Magnetic Flux Conservation 2: #3–8 and Mesh>Size 1: 

#3–8, then the mesh needs clicking Build All (#270 948). Press Study>Compute to solve this 

geophysical problem by the iterative conjugate gradients method, which includes approx. 

80 steps to reach the error threshold (see Convergence Plot). 

 

Figure 4.6 Final solution of the magnetic field of the buried objects: four barrels and two pipes. 

x component of the magnetic flux density on the surface and the flux lines of the magnetic field 

(red). 
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 As you can see in the solution, Results>Magnetic Flux Density Norm>Multislice> 

Expression: mfnc.normB in Unit nT at a depth of Multiplane Data>Z-

planes>Coordinates: 0 m, the magnetic flux density varies within a much wider range, 

between 15000–107 000 nT. The anomaly caused by the new iron pipe suppresses the 

anomalies of the other buried objects. Investigating the effect of the different magnetic 

components, Results>Magnetic Flux Density Norm>Multislice>Expression: mfnc.Bx a 

quadrupole, while Expression: mfnc.By a three-pole anomaly structure appears. The 

observed phenomenon can be understood, when the magnetic flux lines are shown again, 

Results>Magnetic Flux Density Norm>Streamline_R>Enable. By rotating and zooming in 

the model, it is clear that the flux lines are attracted at the southern end of the pipe and they 

discharge at the northern end of the pipe resulting the quadrupole anomaly in Bx (Figure 

4.6).On the other side, By component is enhanced at both ends of the pipe. You can check at 

Results>1D Plot Group, that the effect of the new pipe in the total magnetic flux density 

exceeds the anomalies generated by the barrels. Do not forget to save the modified model, 

Save as>Buried objects 3. 

 

4.3 U-magnet 
 

 In this section the field of a permanent U-magnet will be modeled, Model 

Wizard>3D>AC/DC>Magnetic Fields, No Currents>Add, then Study>Stationary>Done. 

The model geometry of the U-magnet a bit complicated, Geometry_R>Work Plane>Plane: 

yz-plane at x-coordinate: 0.08 m. Beneath the Work Plane, Plane 

Geometry_R>Rectangle>Width: 0.02 m and Height: 0.02 m at a Position>xw: 0.03 m and 

yw: 0 m, then click Build All and Zoom Extents. This square must be rotated to get a U-

magnet, Geometry_R>Revolve>Revolution Angles>Angles: -180ºand Build All Objects. 

We need to fit four pieces to finalize the geometry, Geometry_R>Block>Width: 0.02 m, 

Depth: 0.02 m and Height: 0.04 m at the Position>x: 0.04 m, y: 0.03 m, z: 0.02 m using 

Axis type: x-axis. Click Build All Objects to check whether the block fits to the U-piece. If 

yes, we can continue the geometry building, Geometry>Block 1_R>Duplicate>Position>x: 

0 m, Geometry>Block 1_R>Duplicate>Position>y: -0.05 m, and Geometry>Block 3_R> 

Duplicate>Position>x: 0 m. Now, we have to locate the U-magnet in a closed model domain, 

Geometry_R>Block>Width: 0.4 m, Depth: 0.3 m and Height: 0.3 m at a Position: (-0.20, 

-0.15, -0.15) m. Click Build All Objects and Wireframe Rendering, and you can see that is 

shown in Figure 4.7a, if you worked well. 

 

Figure 4.7 (a) Model geometry and (b) finite element mesh of the U-magnet problem. 
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 In this example the material properties will be chosen from the Materials_R>Add 

Material from Library>Built-In>Iron_R>Add to Component 1. Since the U-magnet is 

located in air, we need to repeat it, Materials_R>Add Material from Library>Built-

In>Air_R>Add to Component 1. The model box must be added to the Selection box in 

Materials>Air: #1. Now, you can close the Add Material window. If you click 

Materials>Iron, you can see that only the U-magnet consists of iron. 

 In Magnetic Fields, No Currents module, the magnetized parts of the magnet should 

be set, Magnetic Fields, No Currents_R>Magnetic Flux Conservation>Domain 

Selection: #3 (farther end of the magnet), and Magnetic Field>Constitutive 

relation>Magnetization>M: (750 [kA/m], 0, 0). You can copy this domain, Magnetic 

Fields, No Currents_R>Magnetic Flux Conservation 2_R>Duplicate>Domain Selection: 

#2 (near end of the magnet), then Magnetic Field>Constitutive 

relation>Magnetization>M: (-750 [kA/m], 0, 0). The part #3 must be removed from this 

Selection box. 

 Mesh generation is very simple, Mesh>Element size: Finer and Build All to get 

57165 finite elements. To look into the model, click Select Boundaries in Graphics window, 

then Click and Hide and denote the three near sides of the model domain. Figure 4.7b shows 

the discretized model geometry. To solve the problem, click Study>Compute. 

 In order the magnitude and the direction of the magnetic flux density to be visualized, 

Results>Magnetic Flux Density Norm>Multislice>Multiplane Data>X-planes: 0 and Y-

planes: 0, while Z-planes>Entry method>Coordinates: 0.01 m, which is the midplane of 

the magnet. Then Results>Magnetic Flux Density Norm_R>Arrow Volume>Arrow 

Positioning>X grid points: 40 and Y grid points: 40, but Z grid points>Entry 

method>Coordinates: 0.01 m. If you click Plot, you can see the direction of the magnetic 

field only within the U-magnet, because the magnitude of B is much higher there. A possible 

solution is, Coloring and Style>Arrow length>Normalized. If you think that the arrows are 

too long, you can scale them by e.g. Scale factor: 0.015. You see better the solution of the 

magnetic flux density, if you click Go To XY View in Graphics window (Figure 4.8). Save 

the model, Save As>U-magnet. 

 

Figure 4.8 Magnetic flux density in the horizontal midplane of the U-magnet and the direction 

of the magnetic field illustrated by normalized red arrows. 
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 Electromagnetic force acting to an iron object can be computed in this model. 

Geometry_R>Cylinder>Radius: 0.01 m and Height: 0.1 m at a Position: (-0.03, -0.05, 

0.01) pointing parallel to the Axis>Axis type: y-axis. Clicking Build All Objects, you will 

see the iron rod in the front of the U-magnet. You can check, whether the rod consists of iron 

in Materials>Iron: #2. For calculation, Magnetic Fields, No Currents_R>Force 

calculation>Force name: rod and add the rod (#2) to the Selection box. Remesh the 

modified model by Mesh>Build All (#74971) and Study>Compute. 

 In Results>Magnetic Flux Density Norm you can see how the iron rod conducts the 

magnetic flux lines (Figure 4.9). We can calculate the attraction force between the rod and the 

magnet, Results>Derived Values_R>Global Evaluation>Expression>Replace 

Expression>Component 1>Magnetic Fields, No Currents>Mechanical>Electromagnetic 

Force: mfnc.Forcex_rod - Electromagnetic force, x component. You can click =Evaluate 

to see the x component of the force, 5.9683 N. In the case of perfectly symmetrical model and 

exact numerical solution, y and z component would be zero. We can check it, Expression: 

mfnc.Forcey_rod and Evalute, Fy≈-7.200∙10
-4

 N, while the z component is Fz≈-0.032 N. Just 

save the model, Save As>U-magnet with rod. 

 

 

Figure 4.9 Magnitude and direction (red arrows) of the magnetic flux density of a U-magnet and 

an iron rod in the horizontal midplane of the model.. 
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5 ELECTROMAGNETISM 
 

 In this chapter two popular geoelectrical tools will be numerically modeled using 

electromagnetic phenomena, the induction geophysical probe used in boreholes and the 

ground penetrating radar (GPR) as a surface exploration tool. 

 

5.1 Induction borehole probe 
 

 As in the most problems in borehole geophysics, 2D axisymmetric model geometry 

will be used, Model Wizard>2D Axisymmetric>AC/DC>Magnetic Fields>Add, but here 

the solution is time-dependent, Study>Time Dependent>Done. Usually, the geometry will 

be as simple as possible, the model domain is a cylinder, Geometry_R>Rectangle>Width: 

1 m and Height: 3 m at the Position: (0, -1) m. Three points will be inserted, the first is the 

transmitter loop generating electromagnetic (EM) field, Geometry_R>Point: (0.05, 0) m, the 

second denotes the transmitter loop, Geometry_R>Point: (0.05, 1) m, and the third one is a 

loop between the transmitter and the receiver to measure the current induced in the rock, 

Geometry_R>Point: (0.5, 0.5) m. We should not forget that the rectangle and the points are a 

cylinder and circles in 2D axisymmetric geometry, where red line denotes the symmetry axis. 

 The Ampère’s Law has already been introduced in part 3.1, but here the problem time-

dependent, therefore the electric field can be calculated from the time-variation of the 

magnetic flux density (Maxwell’s 2
nd

 Law) and the motional induction is also allowed in the 

general Ohm’s Law, see Magnetic Fields>Equation. Let us give the electromagnetic 

parameters of the medium, Magnetic Fields>Ampère’s Law>Relative permeability>μr: 1, 

Electrical conductivity>σ: 1/100 S/m and Relative permittivity>εr: 1. Now, we need to 

define the time-dependent exciting current in the transmitter loop, Magnetic 

Fields_R>Points>Line Current (Out-of-Plane), select point #3 (transmitter loop), and give 

 

Figure 5.1 φ component of the current density excited by the transmitter loop and the direction 

of the magnetic flux density at a time of 5∙10-5 s. 
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the current, Out-of-plane current>I0: 1[A]*sin(2*pi*t*10[kHz]), where 1 A and 10 kHz are 

the amplitude and the frequency of the current, while t denotes the time. Let us use a simple 

automatic mesh, Mesh>Build All, which results in only 311 finite elements. 

 In time-dependent study we must define the parameters of the time stepping, 

Study>Step 1: Time Dependent>Times: range(0, 2e-6, 1e-4) s, which means that the 

calculation starts at t=0 and ends at 10
-4

 s, solutions will be kept in memory at each times of 

2∙10
-6

 s (output times). Now, we can start the solution, Study>Compute. 

 In order to visualize the φ component of the induced current density, 

Results>Magnetic Flux Density Norm>Surface 1>Expression: mf.Jphi with the direction 

of the magnetic flux density, Results>Magnetic Flux Density Norm>Surface 1_R>Arrow 

Surface>Coloring and Style>Arrow length: Normalized, but we do not need the contour 

plot, Contour_R>Disable. Figure 5.1 shows the φ component of the induced current density 

and the direction of the magnetic field at a time of t=5∙10
-5

 s. To view the time-dependent 

exciting and induced current, Results_R>1D Plot Group, then 1D Plot Group_R>Point 

Graph>Expression>Replace expression>Component 1>Magnetic Field>Currents and 

charge>mf.Iop - Out-of-plane current and add #3 (transmitter loop) to Selection box, then 

click Plot. You can see the sinusoid exciting current with an amplitude of 1 A (Figure 5.2a). 

We should duplicate the graph, Results>1D Plot Group>Point 

Graph 1_R>Duplicate>Expression: mf.Jiphi, remove #3 and add #5 (medium) to Selection 

box. Since the exciting current is much larger than the induced one, so Results>1D Plot 

Group>Point Graph 1_R>Disable, the time resolution seems very poor. The induced 

current at the place of the receiver loop, Results>1D Plot Group>Point 

Graph 2_R>Duplicate, change #5 to #4 (receiver loop), and Results>1D Plot Group>Point 

Graph 2_R>Disable. Because the receiver is farther from the transmitter than the point in the 

medium, so the induced current is lower. It is obvious that the time step is not fine enough, 

 

Figure 5.2 Time variation of (a) the exiting current in the transmitter loop, φ component of the current 

density induced (b) in the medium, (c) in the receiver loop after double induction, and (d) the induced 

current density in the receiver loop with higher exciting current frequency and rock conductivity (see 

text for details). 
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thus the time-dependent solution should be tuned. 

 As a default, the solution uses Study>Solver Configurations> Solution>Time-

Dependent Solver>Time Stepping>Steps taken by solver: Free, which means that the time 

step can be as large as the solution is stable, and the output times will be interpolated 

afterwards. Usually, it results in low accuracy, so let us set it to Strict, so the solution will be 

computed at each output time, Study>Compute. The time resolution is much more satisfying, 

Results>1D Plot Group. One can see that the induced current follows a -cos function (Figure 

5.2b), as a π/2 shift from the exciting current due to Maxwell’s 2
nd

 Law (see Eq. (2.1)). The 

amplitude of the induced current density in the receiver loop is jR≈1.4∙10
-8

 A/m
2
, while in the 

medium, Point Graph 2_R>Enable, jm≈5∙10
-7

 A/m
2
. It is worth creating an animation about 

the time variation of the induced current density and the direction of the magnetic flux 

density, Results>Export_R>Animation>File>Format: AVI and Filename: Induction 

probe.avi, then click Export. You can start the animation from your file browser, and see that 

(1) induced current is higher near the transmitter loop, and (2) it has π/2 shift from the 

magnetic field, which follows right-hand rule (Ampère’s Law). The only problem is that we 

need the current induced by the current flowing in medium (and not by the transmitter loop), 

since it yields information about the resistivity of the rock. In one word, we should use double 

induction. But how? 

 In order to calculate the current in the receiver induced by the current flowing in the 

medium induced by the transmitter loop , we need to add the module again, 

Component 1_R>Add Physics and select Recently Used>Magnetic Fields, which becomes 

the module Magnetic Fields 2 (mf2). Let us set Magnetic Fields 2>Ampère’s Law>μr: 1, σ: 

1/100 S/m and εr: 1. In this double induction model, the inducing current is prescribed as an 

external current, Magnetic Fields 2_R>External current density>External current 

density>Je: (0, mf.Jphi, 0) A/m
2
, and the domain #1 must be added to the Selection box. We 

can solve it again, Study>Compute. 

 To look at the double induced current density curve, Results>1D Plot Group>Point 

Graph 2_R>Disable and Point Graph 3>Expression: mf2.Jiphi. Since the graph is quite 

ugly, we should refine the time-dependent solution again by decreasing the maximum time 

step, Study>Solver Configurations> Solution>Time-Dependent Solver>Time Stepping> 

Maximum step: 1e-7 s. We can follow the solution in real-time manner, when we click 

Study>Step 1: Time Dependent>Results While Solving>Plot: 1D Plot Group. Let us start 

the solution again, Study>Compute. Now, the current density in the receiver loop after 

double induction, Results>1D Plot Group, shows 2∙π/2 phase shift, and its amplitude is only 

jR≈1.7∙10
-12

 A/m
2
 (Figure 5.2c). 

 Remembering the point-like coil approximation in the course of Borehole Geophysics, 

the voltage in the receiver coil after double induction is 
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where ω, μ are the angular frequency and the magnetic permeability of the medium, nT and nR 

denote the numbers of turns of the transmitter and the receiver coil, sT and sR are the cross-

sectional areas of turns of the transmitter and the receiver coil, IT is the exciting current in the 

transmitter coil, r and z denote the radial and vertical coordinates in axisymmetrical model 

geometry as well as RT and RR are the distance between the arbitrary circular current induced 

in the rock and the transmitter/receiver coils. Eq. (5.1) says that the voltage/current induced in 

the receiver coil is proportional to the electrical conductivity of the rock, σ and the second 

power of the angular frequency, ω
2
. It is worth checking this property of the model as a 

validation. 
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5.1.1 Parameter test 

 

 First, we increase the conductivity of the medium by one order of magnitude, 

Magnetic Fields> Ampère’s Law>Electrical conductivity>σ: 1/10 S/m, and 

Study>Compute. The current density induced in the ‘receiver coil’ increased by one order of 

magnitude, jR≈1.7∙10
-11

 A/m
2
. Second, we can increase the exciting frequency by a factor of 2, 

Magnetic Fields>Line current (Out-of-Plane)>Out-of-plane current: 

I0=1[A]*sin(2*pi*t*20[kHz]), then Study>Compute. During the solution we can see that the 

numerical duration includes two periods, and the amplitude of the current density induced in 

the receiver loop is four times larger, jR≈6.8∙10
-11

 A/m
2
 owing to the double induction (Figure 

5.2d), Results>1D Plot Group. If we are interested in the current density induced in the 

medium, Results>1D Plot Group>Point Graph 2_R>Enable, the current density is 

jm≈10
-5

 A/m
2
, which involves an increase by a factor of 20 due to (1) one order of magnitude 

increase in σ and (2) an increase by a factor of 2 in ω (there is a single induction in the rock). 

This simple parameter analysis can be saved separately, Save As>Induction probe - 

parameter test. 

 

5.2 Ground penetrating radar 
5.2.1 Homogeneous medium 

 

 We need to choose the appropriate dimension and module, Model Wizard>2D>Radio 

Frequency>Electromagnetic Waves, Frequency Domain (emw)>Add>Study>Frequency 

Domain>Done. The air, Geometry_R>Rectangle>Width: 20 m, Height: 10 m at the 

Position: (-10, 0) m and the subsurface Geometry>Rectangle 1>Duplicate>Position: (-10, 

-10) m are represented by two rectangles. The transmitter is a point source just above the 

surface, Geometry_R>Point at the position of (0, 0.1) m, Build All Objects. 

 We add the material properties of the air from Materials_R>Add Material from 

Library>Built-In>Air. The module solves the Helmholtz equation for the electric field 

vector, E, Electromagnetic Waves, Frequency Domain>Equation. We need another 

domain for the subsurface, Electromagnetic Waves, Frequency Domain_R>Wave 

Equation, Electric>Domain selection: #1 (subsurface - lower domain). To parameterize the 

subsurface, Wave Equation, Electric 2>Relative permittivity>User defined>εr: 9, Relative 

permeability>User defined>μr: 1, and Electrical conductivity>σ: 1/100 S/m. To define the 

point source, Electromagnetic Waves, Frequency Domain_R>points>Electric Point 

Dipole>Point Selection: #4 (point source), Electric current dipole moment direction>np: 

(1, 0) and Electric current dipole moment, magnitude>p: 1 Am. 

 Meshing the simple model, Mesh_R>Size and for the whole model, 

Mesh>Size>Calibrate for Predefined: Finer and for the surroundings of the point source, 

Mesh>Size 1>GEL>Point: #4, Custom>MES: 0.01 m, Mesh_R>Free Triangular and 

Build All to cover the model by 3896 finite elements. 

 In the solution we choose a typical frequency used by the ground penetrating radar 

(GPR), Study>Step 1: Frequency Domain: 100 MHz, Study>Compute. 

 To visualize the solution, Results>Electric Field>Surface>Expression: Ex, as the x 

component of the electric field. We can accentuate the variation of the field by the 

modification of the range, Range>Minimum: -100 V/m and Maximum: 100 V/m. The 

solution seems very noisy due to the imperfect boundary condition, which reflects the EM 

waves. We need to modify it, Electromagnetic Waves, Frequency Domain_R>Scattering 

Boundary Condition>Boundary Selection>All boundaries. Rerun the computation, 

Study>Compute, the solution is much nicer (Figure 5.3). 
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 It is a good idea to try to focus the EM wave downward, into the ground to increase 

the penetration of GPR. For this we modify the geometry by enveloping the point source, 

Geometry_R>Circle>Radius: 0.2 m, Sector angle: 180 deg, and Build All Objects (BAO). 

A good conductor reflects EM waves, Electromagnetic Waves, Frequency 

Domain_R>Perfect Electric Conductor>Boundary Selection: #11, 12 (encasement), then 

Study>Compute. 

 Now, the larger ratio of the energy of EM wave penetrates into the ground. Let us 

investigate also the magnetic field, Results_R>2D Plot Group, and rename it, 2D Plot 

Group 2_R>Rename: Magnetic Field, then Results>Magnetic Field_R>Surface> 

Expression: emw.Hz, which direction is perpendicular to the plane of the display in emw 

module. To highlight the variation of H, Range>Manual color range>Minimum: -0.5 A/m 

and Maximum: 0.5 A/m. In isotropic medium the electric and the magnetic fields are 

perpendicular, and they are also perpendicular to the propagation of EM wave. Calling back 

the relation derived from Helmholtz equation in the course of Geoelectrical Methods, 

 EkHHkE 








 or , (5.2) 

where k denotes the unit vector pointing toward the propagation. Eq. (5.2) says that if E 

propagates in the plane (x, y), so H has only z component, which is perpendicular to the 

display. You can check it, Results>Magnetic Field>Expression: emw.Hx, then emw.Hy, 

then back to emw.Hz. Electric field does not have z component, Results>Electric 

Field>Expression: Ez, and E does not have y component beneath the point source, where 

EM wave propagates downward (-y direction), Expression: emw.ey, then we should set it 

back, Expression>emw.Ex. Let us save the model, Save>GPR - homogeneous. 

 

  

 

Figure 5.3 Horizontal component of the electric field in the air (upper domain) and in the 

subsurface (lower domain) excited by an electric point dipole with a frequency of 100 MHz.. 

http://gali.web.elte.hu/assets/geoelektromos-kutat%c3%b3m%c3%b3dszer.pdf
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5.2.2 Clayey layer 

 

 It is very instructive to examine, how the EM wave behaves in inhomogeneous 

medium. The simplest geological inhomogeneity is a clayey layer inserting in the model, 

Geometry_R>Rectangle>Width: 20 m at Position: (-10, -2) m, BAO. Define the parameters 

of the clayey layer, Electromagnetic Waves, Frequency Domain>Wave Equation, 

Electric 2_R>Duplicate> and Wave Equation, Electric 3>Domain Selection: #2 (clayey 

layer at a depth of 1–2 m) removing other domains. The conductivity of the clay is much 

higher, Electrical conductivity>σ: 1 S/m. Remeshing the model, Mesh and Build All (BA), 

results in 2866 finite elements, then Study>Compute. 

 If you magnify the variation of the electric field, Results>Electric 

Field>Surface>Range>Minimum: -40 V/m and Maximum: 40 V/m, you can see better that 

the electric field is strong in the upper high-resistivity layer (ρ=100 Ωm), and tends to zero in 

the second, clayey layer (ρ=1 Ωm). Figure 5.4 illustrates that there is a distinctly visible 

reflection from the top of the clay. Magnetic field shows similar behavior, Results>Magnetic 

Field. You can simply visualize the skin depth, Results>Magnetic Field_R>Duplicate, and 

Magnetic Field 1>Surface>Expression: emw.deltaS. Remove the tick from 

Range>Manual color range and click Plot. The skin depth, that is the depth, where the 

amplitude of the EM wave attenuates to the values of 1/e, is about 1.6 m in the high-

resistivity, sandy layer. However, in the clay the skin depth reduces to 5 cm! It means that that 

a clayey layer with a thickness of couples of centimeters impedes the penetration of the EM 

wave. Save As>GPR - clayey layer. I note that the skin depth in air tends to infinity owing to 

its conductivity, σ≈0. 

 

5.2.3 Buried iron pipe 

 

 Another typical utilization of GPR is searching buried iron objects, e.g. pipe lines. 

Geometry>Rectangle 3_R>Delete and Geometry_R>Circle>Radius: 0.5 m at Position: (0, 

-1.5) m, BAO. Choose the parameters of iron from Materials_R>Add Material from 

 

Figure 5.4 Horizontal component of the electric field in the air (upper half of the domain) and in 

the subsurface including sandy and clayey (middle) layers excited by an electric point dipole 

with a frequency of 100 MHz.. 
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Library>Built-In>Iron: #4 (iron pipe) and add to the Selection box. Delete 

Electromagnetic Waves, Frequency Domain>Wave Equation, Electric 3_R>Delete, 

which was used for the clayey layer. To refine the mesh, Mesh_R>Size, and you should move 

Size 2 above Free Triangular, then GEL>Boundary: #12, 15 (upper arc of the pipe), and 

Custom>MES: 0.02 m, and reduce Mesh>Size>Custom>MEGR: 1.1, then click BA to get 

14376 finite elements. 

 In order to solve the problem for more frequencies, Study>Step 1: Frequency 

Domain>Frequencies>Range>Start: 100, Step: 100 and Stop: 1000 MHz, and click 

Replace. Click Results While Solving>Plot to see the Electric Field during the solution 

procedure. We need to remove the manual range, Results>Electric Field>Surface>Manual 

Range, and we can start the solution by Study>Compute. 

 We can choose the case of Results>Electric Field>Parameter Value (freq (MHz)): 

400 from the solutions to interpret the physical phenomenon. Figure 5.5 shows that there is 

(1) a strong reflection from the top of the iron pipe, (2) the electric field is zero within the 

pipe. The effect is very similar in the magnetic field, Results>Magnetic 

Field>Surface>Range>Manual color range>Minimum: -4 and Maximum: 4 A/m. The 

skin depth within the pipe is practically zero, Results>Magnetic Field 1, which means that 

the EM wave does not penetrate into the iron pipe. Copying this surface plot, 

Results>Magnetic Field 1_R>Duplicate, then typing Magnetic Field 1.1>Surface> 

Expression: 3e8[m/s]/sqrt(emw.murAv*emw.epsrAv), we can display the propagation 

velocity of the EM wave, v based on the relation of 

 
rr

c
v


 , (5.3) 

where c denotes the light speed. Accordingly, the propagation velocity in the air is 3∙10
8
 m/s, 

that is in the sand is approx. 10
8
 m/s, while in the iron pipe is 5∙10

6
 m/s, notwithstanding the 

energy of the EM wave reflects from the top of the pipe. 

 Finally, we can visualize the electric field beneath the point source, Results>Data 

Sets_R>Cut Line 2D>Line Data from (0, 0) to (0,-1.5) m. By clicking Plot, you can check 

 

Figure 5.5 Horizontal component of the electric field in the surroundings of a buried iron pipe 

line (circle) excited by an electric point dipole with a frequency of 400 MHz. 
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the position of the cut line, which goes from the surface to the interior of the pipe line. To 

display it, Results_R>1D Plot Group, then 1D Plot Group_R>Line Graph>Data Sets: Cut 

Line 2D, Expression: Ex as a function of the depth, x-Axis Data>Parameter>Expression: 

y. All solutions are shown in the figure, and each frequency dies away in the iron pipe. If you 

want to present only one electric wave frequency, you can choose it from Parameter 

selection (freq)>From list: 400 and click Plot. Do not forget saving the model, Save 

As>GPR - iron pipe. 
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6 GEOTHERMICS 
 

 Via three simplex numerical models we present the phenomenon of heat conduction 

and heat source in homogeneous and inhomogeneous medium, we investigate how the output 

temperature and heat power depend on the amount of the circulating fluid in a borehole heat 

exchanger, and finally, we illustrate how the surface heat flux above a 3D cooling magma 

body varies in time. 

 

6.1 Role of heat conduction and heat source 
6.1.1 Homogeneous medium 

 

 Here we compile an artificial 2D model to get to know the operation of Heat Transport 

module, Model Wizard>2D>Heat Transfer>Heat Transfer in Solids>Add and 

Study>Stationary>Done. Table 6.1 shows the necessary model parameters defined in 

Global Definitions>Parameters. 

 

Name Expression Value Description 

T0 10 [degC] 283.15 K Surface temperature 

T1 60 [degC] 333.15 K Bottom temperature 

Table 6.1 Parameter definition 

 

 To create the model geometry, Geometry_R>Square>Side length: 1000 m at 

Position: (-500, -1000) m, then BAO. 

 Defining the model properties and boundary conditions, Heat Transfer in 

Solids>Solid>Thermal conductivity>User defined>k: 3 W/(m K), Density>User 

defined>ρ: 2500 kg/m
3
, and Heat capacity at constant pressure>User defined>Cp: 

1000 J/(kg K). Equation shows the heat transport equation including terms from the left-side: 

heat advection, heat conduction, heat source and other additional terms. Default boundary 

condition suggested by the module: Thermal Insulation, which is appropriate for the side 

walls. However, the horizontal boundaries will be isothermal, the surface is Heat Transfer in 

Solid_R>Temperature>Boundary Selection: #3 (surface), where the temperature is T0: T0 

from the defined parameters, and the bottom boundary is Heat Transfer in 

Solid_R>Temperature>Boundary Selection: #2 (bottom), where the temperature is T0: T1. 

 The mesh is just simply, Mesh>BA using for discretization 578 finite elements, then 

Study>Compute. 

 It is worth changing the color table from Thermal Light to 

Results>Temperature>Surface>Coloring and Style>Color table: Rainbow, thus cold 

zones are denoted by cold colors, and we should use Unit: degC and click Plot. Coloring 

suggests that the temperature increases continuously downwards, but we should display it 

quantitatively along a vertical section, Results>Data Sets_R>Cut Line 2D>Point 1: (0, 0) to 

Point 2: (0, -1000) m, you can click Plot to see the section. To plot the temperature profile, 

Results_R>1D Plot Group, then 1D Plot Group_R>Line Graph>Data set: Cut Line 2D in 

Unit: degC as a function of x-Axis Data>Parameter>Expression: y, then Plot. It is clear 

that the temperature increases linearly downwards owing to this simple geometry, boundary 

conditions, homogeneous and isotropic medium etc. This base model should be saved, 

Save>Geothermics - homogeneous medium. 
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6.1.2 Layered model 

 

 In geology, the most common heterogeneity is the layering. As a first step, we insert a 

clayey layer with reduced thermal conductivity, Geometry_R>Rectangle>Width: 1000 m 

and Height: 200 m at Position: (-500, -600) m, then BAO. Heat Transfer in 

Solids>Solid_R>Duplicate, then Solid 2>Domain Selection: #2 (middle, clayey layer) and 

Thermal conductivity>k: 2 W/(m K). If you click Study>Compute, the mesh generation 

will be done automatically, because the geometry was modified after the last meshing. 

 Color scale does not show unequivocal variation in temperature distribution, but the 

graph covers, Results>1D Plot Group, that in the clayey layer with lessened thermal 

conductivity the temperature gradient is higher. It is clear, since the vertical heat flux has to 

be constant in stationary solution (if it would not be, some zones would be warming up, while 

others would be cooling down, but it would not be stationary). Knowing Fourier’s 1
st
 Law 

concerning heat conduction, 

 Tgradkq  , (6.1) 

where q, k and T denotes the heat flux vector, the thermal conductivity matrix of the medium 

and the temperature, respectively. So, if q is constant and k is reduced, the temperature 

gradient must be enhanced, like in the clayey layer. The direction of the conductive heat flux 

can be illustrated by arrows, Results>Temperature_R>Arrow Surface>Expression>X 

component: ht.dfluxx and Y component: ht.dfluxy, then Coloring and 

Style>Color>White. You can save it separately, Save As>Geothermics - layering. 

 

6.1.3 Good thermal conductor 

 

 To magnify the effect of thermal conductivity, an extremely good conductor will be 

inserted into the model, Geometry_R>Circle>Radius: 100 m, Position: (0, -800) m, then 

BAO. We need to set the thermal conductivity of the new object, Heat Transfer in 

Solids>Solid 2_R>Duplicate, and Solid 3>Domain Selection: #4 (circle), and other domains 

must be removed, then Thermal conductivity>k: 100 W/(m K). Click Study>Compute to 

 

Figure 6.1 Temperature field and heat flux lines (white) in the model including a middle clay 

layer with reduced and the circle-shaped object with enhanced thermal conductivity. 
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be solved. 

 In order to highlight the path of the heat, Results>Temperature _R>Streamline: #7 

(surface) can be marked in the Selection box, as a boundary through which 20 streamlines 

overpass. You can choose Coloring and Style>Color>White and click Plot, to the total heat 

flux path be displayed. Figure 6.1 shows the temperature field and the total heat flux 

streamline after the arrows were cleared away, Result>Temperature>Arrow 

Surface_R>Disable. Last, we should save it, Save As>Geothermics - good conductor. 

 

6.1.4 Heat source 

 

 Finally, we study the effect of the heat source in the medium, Heat Transfer in 

Solids_R>Heat Source>Domain Selection: #4 (circle), and General source>Q0: 

0.005 W/m
3
, then Study>Compute. Figure 6.2a emphasizes that the circular heat source has 

the maximum temperature, since more streamlines originate from its interior, and it heats also 

downwards. This suggestion is proved by Results>1D Plot Group, because within the heat 

source the temperature exceeds 60 ºC, that is the temperature of the bottom boundary (Figure 

6.2b). Terminally, Save As>Geothermics - heat source. 

 

6.2 Borehole heat exchanger 
 

 In this chapter we investigate how the output temperature and heat power depends on 

the fluid velocity circulating in a geothermal borehole heat exchanger. Model Wizard>2D 

Axisymmetric>Heat Transfer>Heat Transfer in Solids>Add, then Study>Stationary> 

Done. First, we define the necessary model parameters in Global Definitions>Parameters, 

which can be found in Table 6.2. Based on geometrical considerations, the fluid velocity 

flowing upwards in the inner pipe is, 

 d

in

inout

du w
R

RR
ww 3

2

22




 , (6.2) 

three times larger than the downward velocity in the outer pipe, since the cross sectional area 

of the inner pipe is lower by a factor of three. 

 The model includes three coaxial cylinders, the rock, where the only heat transfer 

mechanism is the conduction, Geometry_R>Rectangle>Width: 100 m, Height: 100 m at 

 

Figure 6.2 Stationary solution of the heat transfer for a model with a middle clay layer having low 

thermal conductivity and a circle-shaped thermally good conductor. In the latter object the heat 

production is 0.005 W/m
3
. (a) Temperature field with heat flux lines (white), (b) Vertical temperature 

profile through the middle of the model domain. 
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Position: (0, -100) m, the outer pipe, where the cold fluid flows down, 

Geometry_R>Rectangle>Width: Rout, Height: 80 m at Position: (0, -80) m, and the inner 

pipe, where the warm fluid flows upwards, Geometry>Rectangle 2_R>Duplicate and 

Rectangle 3>Width: Rin, then BAO. The size of the borehole heat exchanger (BHE) is much 

less than that of the model domain, but you can see it after zooming in the left upper corner of 

the model geometry. 

 

Name Expression Value Description 

T0 285 [K[ 285 K Surface temperature 

T1 289 [K] 289 K Bottom temperature 

Rout 0.1[ m[ 0.1 m Outer pipe radius 

Rin Rout/2 0.05 m Inner pipe radius 

wd 1e-4 [m/s] 1E-4 m/s Down velocity 

wu wd*((Rout^2-Rin^2)/Rin^2) 3E-4 m/s Up velocity 

Table 6.2 Parameter definition 

 

 For the first time, we will use probe plots to analyze easily the effect of fluid 

circulation. The first probe plot is a checking probe by which the velocity of the outflowing 

water will be measured, Definitions_R>Probes>Boundary Probe>Source Selection: #5 

(top of the inner pipe, where the fluid flows out), Variable name: w_out, Expression: ht.uz 

(vertical velocity in Heat Transfer module), Table and Window Settings>Plot window>+ to 

get Probe Plot 1. The second probe plot is the average temperature at the bottom of the BHE, 

Definitions_R>Probes>Boundary Probe>Source Selection: #7 (bottom of the outer pipe), 

Variable name: T_b, Expression: T (temperature), Table and Window Settings>Plot 

window>+ to get Probe Plot 2. The third probe plot is the average temperature of the 

outflowing water, Definitions>Boundary Probe 1_R>Duplicate>Source Selection: #5 (top 

of the inner pipe), Variable name: T_out, Expression: T, Table and Window 

Settings>Plot window>Probe Plot 2. And the last probe plot measures the outflowing heat 

power, Definitions>Boundary Probe 3_R>Duplicate>Source Selection: #5 (top of the 

inner pipe), Variable name: Q_out, Expression: ht.Cp*ht.rho*ht.uz*(T-T0)*Rin^2*pi, 

Table and Window Settings>Plot window>+ to get Probe Plot 3. The heat power defined 

above is 

 ATTwcQ upout )( 0 , (6.3) 

where cp, ρ, w, T0 and A=Rin
2
π denote the specific heat, the density and the vertical velocity of 

the water, the inflow water temperature and the cross-sectional area of the outflow water. 

 Now, we need to fill in the domains with materials, Materials_R>Add Material from 

Library>Built-In>Water for the BHE, and Materials_R>Add Material from 

Library>Built-In>Material Library>Minerals, Rocks and Soils>Sandstone (quartzitic) 

>Sandstone (quartzitic)>Sandstone (quartzitic) [solid, parallel to bed] for the medium, 

Geometric Entity Selection: #1. At this moment you get a warning, because the heat 

capacity of the sandstone is not defined, but needed for the calculation, so fill in the table with 

an appropriate value, Material Contents>Cp: 1000 J/(kgK). The warning will disappear. 

 At this stage the domain properties and the boundary conditions must be prescribed. 

You need to add two fluid modules for the BHE, Heat Transfer in Solids_R>Fluid>Domain 

Selection: #3 (outer pipe), Velocity Field>u: (0, -wd), because the water flows downwards. 

And for the inner pipe, Heat Transfer in Solids>Fluid 1_R>Duplicate>Domain Selection: 

#2 (inner pipe), Velocity Field>u: (0, wu), because the water flows upwards. Going on the 

boundary conditions, the temperature of the surface and the inflow water is T0, Heat Transfer 

in Solids_R>Temperature>Boundary Selection: #8, 10, Temperature>T0: T0, and at the 
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bottom of the model, Heat Transfer in Solids_R>Temperature>Boundary Selection: #2, 

Temperature>T0: T1. The temperature at the bottom of the inner pipe is equal to that of the 

outer pipe, here the water turns back, Heat Transfer in Solids_R>Temperature>Boundary 

Selection: #4, Temperature>T0: T_b. You get a warning of ‘Unknown variable T_b’, 

because T_b will be calculated later, during the simulation as a boundary probe. So, you can 

skip the warning. At the top of the inner pipe, Heat Transfer in 

Solids_R>Outflow>Boundary Selection: #5, which ensures that the water does not cool 

through the boundary (zero heat flux, see Equation). Finally, the descending cool and the 

ascending warm pipes should be isolated by a low-conductivity material, Heat Transfer in 

Solids_R>Thin Layer>Boundary Selection: #6, Layer thickness: 5e-3 m, Layer thermal 

conductivity: 0.1 W/(m K), Layer density: 2500 kg/m
3
, Layer heat capacity: 1000 J/(kgK). 

The outer side wall of the model is thermally insulated, and the axis is symmetrical, as it is 

prescribed by the default boundary conditions. 

 Meshing the model is much more simple, Mesh_R>Free Quad>BA, which gives 

11468 finite elements. The problem will be solved for more circulation velocity values, thus 

we use a parametric sweep for wd, Study_R>Parametric Sweep>Study Settings>+ and we 

should choose wd (Down velocity) and type the values for the solutions: 1e-4 2e-4 5e-4 1e-3 

2e-3 3e-3 5e-3 1e-2 2e-2 with Parameter unit: m/s. And now you can click 

Study>Compute. During the solution probe plots are calculated and shown in Graphics 

window. 

 Results>Temperature 3D shows the nine numerical solutions of the problem, it is 

worth changing color table, Surface>Coloring and Style>Color table>Rainbow. At highest 

water velocity (wd=0.02 m/s) the BHE cools down its surroundings observably (Figure 6.3a), 

while at the lowest velocity (wd=10
-4

 m/s), Parameter value (wd (m/s)): 1e-4, the solution 

for the temperature seems to reflect the conductive solution, T increases linearly downwards 

(Figure 6.3b). Let us look at the probe plots in Graphic window, Probe Plot 1 shows that wu 

increases linearly with wd, and its values three times larger, as it was expected. Probe Plot 2 

displays that Tb decreases as the water velocity increases, since it has less time to be warmed 

up. The temperature of the outflow water has a maximum at wd=0.002 m/s, because at this 

velocity the water is slow enough to be warmed up in the outer pipe, and it is fast enough not 

to be cooled down in the inner pipe. Probe Plot 3 states that the outcome heat power 

monotonically increases with wd, however the slope of Qout decreases. It can be explained by 

the fact that, although the outflow temperature (Tout) decreases with the circulation velocity 

(wd), but the amount of the water (wuRin
2
π) increases. It is worth studying the temperature 

profile along the pipes, Results_R>1D Plot Group, then 1D Plot Group>Line 

 

Figure 6.3 Temperature field in the ambient rock of the BHE with (a) high circulation velocity and (b) 

low circulation velocity. 
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Graph>Selection: #3, 9, x-Axis Data>Parameter>Expression: z and click Legends>Show 

legends, press the button Plot. At the lowest circulation velocity the water warms up linearly 

downwards, then it cools down almost linearly upwards. As wd increases the deviation at the 

bottom of the BHE becomes larger. It must be an inconsistency in the numerical model, which 

should be eliminated. To understand the problem, Results_R>1D Plot Group, and 1D Plot 

Group_R>Line Graph>Selection: #4, 7 (bottom of BHE), x-Axis Data>Expression: r, then 

Plot. For the first look, it is strange, because the temperature varies radially within the outer 

pipe. The reason for this unrealistic behavior is that the module uses laminar approximation, 

so if one particle starts along the verge of the outer pipe, it will move here till the bottom of 

the BHE. Therefore, the radial heat transport occurs only by conduction. In natural 

circumstances, the flow in the BHE is rather turbulent, thus the flow has also radial 

component, which mixes the water and abolish the radial temperature differences. In order to 

eliminate this discrepancy from our model, we will artificially increase the radial thermal 

conduction within the pipes. 

 To increase the radial thermal conductivity within the pipes as a kind of imitation of 

turbulent flow, Heat Transfer in Solids>Fluid 1>Thermal conductivity>User 

defined>Diagonal: (60, 0.6) W/(m K), and also in the inner pipe, Heat Transfer in 

Solids>Fluid 2>Thermal conductivity>User defined>Diagonal: (60, 0.6) W/(m K). We can 

rerun the model, Study>Compute. 

 We managed to eliminate the problem, Results>1D Plot Group 7 shows that there is 

no radial temperature variation within the pipe. Probe Plot 2 illustrates that now the 

maximum outflow temperature occurs at wd=0.003 m/s (Figure 6.4a), and Probe Plot 3 says 

that the maximum circulating velocity results in approx. Qout≈700 W heat power (Figure 

6.4b) in stationary calculation. Vertical temperature profiles within the pipes are shown in 

Figure 6.5, but some solutions were expelled, Results>1D Plot Group 6>Data>Parameter 

Selection (wd)>From list: 1e-4, 0.001, 0.003, 0.01 and Plot. Now it is clear, that the 

downward velocity of wd=10
-4

 m/s is too slow, thus the water cools down in the ascending 

branch. On the other hand, wd=10
-2

 m/s is too fast, thus the water cannot warm up in the 

descending branch. From the point of view of the outflow water temperature, wd=3∙10
-3

 m/s is 

the optimum point. 

 Finally, we study also the radial temperature variation in the rock generated by the 

BHE, Results>Data Sets_R>Cut Line 2D>Point 1: (0, -40) m to Point 2: (1, -40) m, Plot 

shows that the section is situated at the middepth of the BHE. Results_R>1D Plot Group>, 

and 1D Plot Group 8>Line Graph>Data>Data set: Cut Line 2D, x-Axis 

Data>Expression: r, then click Show legends. The plot illustrates that wd≥0.001 m/s is able 

 

Figure 6.4 (a) The outflow and the bottom temperature of the BHE and (b) the outcome heat power 

from the BHE as a function of the circulation water velocity in the outer pipe. 
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to cool down the medium in the surroundings of the BHE, since the conductive temperature at 

the depth of 40 m is 286.6 ºC. We need to save the model, Save>BHE. 

 

6.3 Cooling volcano 
 

 In the last model in Geothermics the temperature and the surface heat flux variation 

created by a 3D cooling magma body will be investigated, thus the only heat transport 

mechanism is the conduction. It permits for us the calculation of a time-dependent 3D 

numerical model, Model Wizard>3D>Heat Transfer>Heat Transfer in Solids>Add, and 

Study>Time Dependent>Done. Table 6.3 summarizes the defined parameters in Global 

Definitions>Parameters. Since this problem is time-dependent, we need also an initial 

condition for the temperature, as a conductive temperature distribution increasing linearly 

downwards. It can be defined in Global Definitions_R>Variables (Table 6.4). 

 

Name Expression Value Description 

T0 285 [K[ 285 K Surface temperature 

T1 1100 [K] 1100 K Bottom temperature 

d 30 [km] 30000 m Crust thickness 

Table 6.3 Parameter definition 

 

Name Expression Unit Description 

T_in T0-(T1-T0)/d*z K Initial temperature profile 

Table 6.4 Variable definition 

 

 The bedding medium is, Geometry_R>Block>Width: 1e5 m, Depth: 1e5 m, Height: 

d, at Position: (-5e4, -5e4, -d) m. The magma body is situated 3000 m deep, 

Geometry_R>Cylinder>Radius: 3000 m, Height: 5000 m at Position: (0, 0, -8000) m. For 

accurate calculation above the magma body, click Geometry_R>More Primitives>Point, 

then BAO and Wireframe Rendering. 

 We set the model parameters characterizing the material properties, boundary and 

initial conditions for the bedding sediments, Heat Transfer in Solids>Solid>Thermal 

 

Figure 6.5 Vertical temperature profiles along the descending and the ascending branch of BHE 

at different water circulation velocities wd. 
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conductivity>k: 2 W/(m K), Density>ρ: 2500 kg/m
3
 and Heat capacity at constant 

pressure>Cp: 1000 J/(kgK) and for the magma body, Heat Transfer in 

Solids>Solid_R>Duplicate, and Solid 2>Domain Selection: #2 (magma body), Density>ρ: 

3300 kg/m
3
. The surface and the bottom of the model is isothermal, Heat Transfer in 

Solids_R>Temperature>Boundary Selection: #4 (surface), Temperature>T0: T0, and 

Heat Transfer in Solids_R>Temperature>Boundary Selection: #3 (bottom), 

Temperature>T0: T1. We can allow the isothermal boundary conditions for the side walls as 

a default. The initial condition for the temperature of the sediments is the conductive 

temperature profile defined in Table 6.4, Heat Transfer in Solids>Initial 

Values>Temperature>T: T_in. However, it is assumed that the magma body migrated 

suddenly from the mantle, so its temperature was kept, Heat Transfer in Solids_R>Initial 

Values, and Initial Values 2>Domain Selection: #2 (magma body), Temperature>T: T1. 

 We compile an appropriate discretization for the problem, Mesh_R>Size, and 

Size>Custom>MEGR: 1.3, Size 1>Geometric Entity Selection>GEL>Boundary: #6–11 

(surface of magma body), then Custom>MES: 500 m. For the surface, Mesh_R>Size, and 

Size 2>Geometric Entity Selection>GEL>Boundary: #4 (surface), then Custom>MEGR: 

1.15. For the point above magma chamber, Mesh_R>Size, and Size 3>Geometric Entity 

Selection>GEL>Point: #9 (point above the magma chamber), then Custom>MES: 50 m. As 

usual, we apply tetrahedral discretization, Mesh_R>Free Tetrahedral>BA, which results in 

64064 finite elements. Figure 6.6 shows the meshed magma body from below, after the side 

walls and the bottom boundary were hidden, click Select Boundaries in Graphics window 

and Click and Hide. 

 In order to check the initial condition, Study_R>Get Initial Value, then 

Results>Temperature>Surface_R>Disable and Results>Temperature_R>Slice>Plane 

Data>YZ-planes>Planes: 1 creating a vertical section for the temperature profile. The 

temperature increases linearly in the ambient rock, while it is 1100 K in the magma body. It is 

worth removing the Coloring and Style>Color legend. Presenting the magnitude of total 

heat flux on the surface, Results>Temperature_R>Slice>Plane Data>XY-planes>Planes, 

Entry method>Coordinates>Z-coordinates: 0 m, Expression>ht.tfluxMag in Unit: 

mW/m
2
. At the initial state the surface heat flux is constant, 54.33 mW/m

2
 (Figure 6.7a). 

Click Go to Default View. 

 

Figure 6.6 Illustration of the mesh of the magma chamber and the surface above. 
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 Let us set the parameters of the solution, Study>Step 1: Time Dependent>Study 

Settings>Time unit: a and Times: range(0, 10000, 400000) to simulate the solution to 

0.4 Myr with an output time of 10 kyr. Click Results While Solving>Plot Group: 

Temperature (ht), Update at: Time steps taken by solver, and set the time stepping 

method, Study>Solver Configurations>Solution>Time-Dependent Solver>Time 

Stepping>Steps taken by solver: Strict. Now, you can start the simulation, 

Study>Compute. During the computation you can rotate the model to look at the temperature 

of the magma chamber and the ambient rock, as well as the surface heat flux. The temperature 

of the magma body is likely to decrease with time resulting a time-dependent surface heat flux 

anomaly above that. Figure 6.7b displays the surface heat flux and the vertical temperature 

profile at a time of 90 kyr. 

 To study the temperature variation both in time and space, 

Results>Temperature>Slice 1_R>Disable, Results>Data Sets_R>Cut Line 3D>Point 1: 

(-10000, 0, 5500) m to Point 2: (10000, 0, -5500) m crossing the magma chamber at 

middepth, Plot. Then we create a graph, Results_R>1D Plot Group, 1D Plot 

Group_R>Line Graph>Data>Data set: Cut Line 3D, x-Axis Data>Parameter> 

Expression: x, click Plot. Figure 6.8 illustrates the temperature distribution crossing the 

magma body at each output time of 10 kyr. If you visualize only the initial state and the 

temperature after 160 kyr, Data>Time selection>From list>Times (a): 0, 1.6E5, and Plot, 

you can see that the initial temperature anomaly of the magma chamber reduced to approx. 

1/e, which is the characteristic time scale of this conductive regime. Additionally, we can look 

at the time variation of the surface heat flux above the magma body, Results_R>1D Plot 

Group, and 1D Plot Group 4_R>Point Graph>Selection: #9 (point above the magma 

 

Figure 6.7 Vertical temperature profile crossing the magma body and surface heat flux (a) in the initial 

state and (b) 90 kyr later. 

 

 

Figure 6.8 Horizontal temperature profiles 

crossing the magma body at each 10 kyr. 

 

Figure 6.9 Time-variation of the surface heat flux 

above the magma body. 
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chamber), y-Axis Data>Expression>ht.tfluxMag in Unit: mW/m
2
, then click Plot. Figure 

6.9 demonstrates that the surface heat flux has a maximum of almost 200 mW/m
2
 at 90 kyr 

after the magma started cooling. 

 We can export the surface heat flux variation as an animation, 

Results>Export_R>Animation>File>Format: AVI, Filename: Cooling volcano, 

Frames>Frame selection: All, and click Export. Finally, we can study the heat flux 

streamlines, Results>Temperature_R>Streamlines>Streamline Positioning>Start point 

controlled, Entry method>Number of points: 50, then click Plot. Using the arrows in the 

upper part of Settings window, you can find that the magma chamber heats the ambient rock 

only if t≤240 kyr (Figure 6.10). Do not forget saving your model, Save>Cooling volcano. 

 

 

Figure 6.10 Surface heat flux and the heat flux lines (red) at a time of 240 kyr. 
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7 GROUNDWATER FLOW 
 

 In this chapter groundwater flow modeling will be presented using Dracy’s Law. In 

the first part a 2D stationary problem will be compared with the analytical solution, as well as 

the effect of anisotropy and inhomogeneity will be studied. Then, a hypothetical 

contamination transport problem will be investigated coupled with groundwater flow, and a 

possible treatment will be suggested. 

 

7.1 Unit basin 
7.1.1 Homogeneous and isotropic medium 

 

 We examine here how groundwater flow is controlled by a cosinusoid water table 

variation, Model Wizard>2D>Fluid Flow>Porous Media and Subsurface Flow>Darcy’s 

Law (dl)>Add>Study>Stationary>Done. Model domain is a simple rectangle, 

Geometry_R>Rectangle>Width: 1000 m and Height: 300 m at Position: (0, -300) m, and 

BAO. Porous fluid, as water is added from Materials_R>Add Material from 

Library>Built-In>Water, liquid. Porosity and permeability are necessary parameters for the 

problem, but not respecting the water, so we can ignore the warning. 

 In Darcy’s Law>Fluid and Matrix Properties>Equation we can check the relations 

consisting of the conservation of mass in stationary problem and the Darcy’s Law, which uses 

the pressure p as unknown. Parameters for water are taken From material, but for Matrix 

Properties>Porosity>User defined: 0.1 and Permeability model>Hydraulic conductivity: 

1e-4 m/s. Default boundary condition, No Flow are applicable for the boundaries excepting 

for the surface, where the cosinusoid water table must be prescribed as a driving force, 

Darcy’s Law_R>Hydraulic Head>Boundary Selection: #3 (surface) and Hydraulic 

head>H0: h0. Posteriorly, we need to define the water table, Global 

Definitions_R>Variables>Name: h0, Expression: 10[m]*cos(pi*x/1000[m]), Description: 

Water table. Now, the warning will disappear in the boundary condition. 

 Meshing is simple, Mesh_R>Size, and Size>Custom>MES: 10 m, MEGR: 1.2. 

Then, Size 1>GEL>Boundary>Selection: All boundaries, Custom>MES: 5 m. We need to 

select the type of meshing, Mesh_R>Free Triangular, and BA to get 12572 finite elements. 

Then, Study>Compute. 

 For visualization of the result, we can display the hydraulic head instead of pressure, 

Results>Pressure>Surface>Expression: dl.H and Plot. The hydraulic head varies within the 

range of (-10, 10) m in the whole domain, maximum is at the top left corner, and minimum is 

at the top right corner (Figure 7.1). Streamlines show the path of the flow, 

Results>Pressure_R>Streamline>Streamline Positioning>Positioning: Magnitude 

controlled and Density: 10. It is worth presenting also the hydraulic head contours by 

 

Figure 7.1 Hydraulic head field, Darcy flux lines (black) and head isocontours (white) of the 

groundwater flow under cosinusoid water table. 
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Results>Pressure_R>Contours>Expression: dl.H, Levels>Number of levels>Total levels: 

10. We can choose a different color, Coloring and Style>Color: White. It is clear, that the 

water flows from left to right following the decrease of the head. In addition, streamlines are 

perpendicular to the head contours pointing out, that in isotropic medium the flow occurs 

toward the maximal head decrease. To look at the depth profile of different parameters, we 

define a vertical midsection, Results>Data Sets_R>Cut Line 2D: (500, 0) m to (500, 

-300) m, you can Plot the section. 

 To create a graph, Results_R>1D Plot Group, and 1D Plot Group_R>Line 

Graph>Selection: #1 (left boundary), Expression: dl.H, x-Axis 

Data>Parameter>Expression: y. If you Plot the graph, you will see how the head 

decreases with the depth, which is typical in the recharge zones. 

 On the other side, Clear Selection, and add #4 (right boundary) to Selection box, then 

press Plot. Here the head increases with depth, as it is usual in the discharge zone. The 

rate of the head variation is known from analytical solution, which was solved in the 

course of Earth’s Flow Systems I, the hydraulic head is 
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where H, d, l and ε denote the amplitude of the water table at the surface, the depth 

and the length of the model as well as the anisotropy coefficient, respectively. In this 

numerical model, H=10 m, d=300 m, l=1000 m, while ε=Kxx/Kyy=1 in isotropic 

medium. Eq. (7.1) reveals that the head varies with the depth as a cosh function. 

 To get the horizontal Darcy flux along the surface, remove #4 and add #3 (surface) 

from/to Selection box, Expression: dl.u and Parameter>Expression: x, then Plot. 

You see that the horizontal velocity is maximal at the middle of the surface, where the 

slope of the water table is the largest. 

 The vertical profile of the horizontal velocity along the midline, Data>Data Sets>Cut 

Line 2D and  x-Axis Data>Parameter>Expression: y, Plot shows that the horizontal 

Darcy flux decreases with depth (~sinh), but it is nonzero at the bottom of the model. 

It means that there is horizontal flow along the bottom, which is also a flow path. 

 The surface vertical velocity, Data>Data Set: Study 1/Solution 1, add #3 (surface) to 

the Selection box, Expression: dl.v, then x-Axis Data>Parameter>Expression: x, 

then Plot it. The graph illustrates that the vertical flux is negative (downwards) on the 

left part of the model domain, while it is positive (upwards) on the right part. Former 

one indicates the recharge area, while the latter one indicates the discharge area. 

Finally, let us visualize the magnitude of the Darcy flux, Results>Pressure>Surface> 

 

Figure 7.2 Darcy flux magnitude, Darcy flux lines (black) and head isocontours (white) of the 

groundwater flow under cosinusoid water table. 

http://gali.web.elte.hu/assets/f%c3%b6ldi-%c3%a1raml%c3%a1sok-fizk%c3%a1ja.pdf
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Expression: dl.U in Unit: m/yr. Figure 7.2 displays that the flow is slow in the vicinity of 

the lower corners of the model domain, while it is more intense in the near-surface, and the 

Darcy flux is maximal in the shallow zone of the midline of the model. You should not forget 

to Save>Groundwater flow - homogeneity. 

 

7.1.2 Anisotropy 

 

 In order to investigate the influence of hydraulic conductivity anisotropy on the flow 

and head distribution, we introduce a parametric sweep of ε to decrease gradually the vertical 

conductivity of the medium, Global Definitions>Parameters>Name: e, Expression: 1 and 

Description: Anisotropy coefficient. Darcy’s Law>Fluid and Matrix Properties>Matrix 

Properties>Hydraulic conductivity>Diagonal: (1e-4, 1e-4/e) m/s. Going to 

Study 1_R>Parametric Sweep>Add (+), Parameter name: e, Parameter value list: 1 10 

100 1000, Parameter unit: 1. Click Plot in Output While Solving. Now, you can start the 

computation by Study 1>Compute. 

 As the anisotropy increases, a slow/sluggish zone grows in the deeper domain, and the 

streamy zone contracts toward the surface (Figure 7.3), Results>Pressure (use arrows in 

Settings window). It can be easily explained, since the enhanced anisotropy reduces the 

vertical conductivity and so the vertical flow. If you set the Data>Parameter value (e(1)): 10 

and Plot, you can see that streamlines have not already been perpendicular to the head 

isocontours. Accordingly, the direction of the flow is controlled by both the head gradient and 

the hydraulic conductivity matrix. 

 We can see some Darcy flux and head sections of the solution, Results>1D Plot 

Group>Line Graph> 

 Selection: #1 (left side), Expression: dl.v, x-Axis Data>Parameter>Expression: y, 

and Plot. Obviously, as the anisotropy coefficient increases, the vertical velocity 

decreases due to the reduced vertical conductivity. You can click Legends>Show 

legends to be able to discriminate between the curves. 

 You can check the horizontal velocity along the vertical midline, Results>1D Plot 

Group>Line Graph>Data>Data set: Cut Line 2D, Expression: dl.u, and Plot. The 

 

Figure 7.3 Effect of hydraulic conductivity anisotropy on the groundwater flow. Darcy flux magnitude, 

Darcy flux lines (black) and head isocontours (white) at different anisotropy ratios: (a) ε=1, (b) ε=10, 

(c) ε=100 and (d) ε=1000. 
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graph shows that the anisotropy ε=100 is high enough not to be present flow along the 

bottom of the model. If ε=1000 there is no relevant water motion below the depth of 

50 m. 

 The surface horizontal velocity, Data>Data set: Study 1/Solution 1, Selection: #3, x-

Axis Data>Parameter>Expression: x, is not influenced by the anisotropy of the 

medium. 

 However, the surface vertical velocity is affected by the anisotropy, Expression: dl.v 

and Plot. The higher the anisotropy is, the lower the vertical Darcy flux is. 

Finally, we need to Save As>Groundwater flow - anisotropy. 

 

7.1.3. Three-layer model 

 

 The most frequently occurrent heterogeneity in the nature is the geological layering, in 

this part the effect of a low-conductivity, clayey bedded layer will be analyzed by parametric 

sweep. The hydraulic conductivity of the middle, clayey layer is, Global 

Definitions>Parameters>Name: K, Expression: 1e-4 [m/s] and Description: Hydraulic 

conductivity. The model geometry must be modified, Geometry>Rectangle 1_R> 

Duplicate, and Rectangle 2>Height: 100 m and Position: (0, -200) m. Press BAO to create 

the 3-layer model geometry. 

 A new module is needed for the bedded layer, Darcy’s Law_R>Fluid and Matrix 

Properties, then Fluid and Matrix Properties 2>Domain Selection: #2 (middle layer), 

Matrix Properties>Porosity: 0.1 and Permeability model>Hydraulic conductivity>K: K. 

We should not forget that this model is isotropic, so Darcy’s Law>Fluid and Matrix 

Properties 1>Matrix Properties>Permeability model>Hydraulic conductivity>Isotropic. 

 Mesh>BA results in 17230 elements. Let us choose in Study 1>Parametric 

sweep>Parameter name: K (Hydraulic conductivity), Parameter value list: 1e-4 5e-5 

2e-5 1e-5 5e-6 2e-6 1e-6 in Parameter unit: m/s. Using this setting, the hydraulic 

conductivity of the bedded layer decreases by two orders of magnitude after 

Study>Compute. 

 Figure 7.4 illustrate that as K decreases in the middle layer, the flow slows down in 

the bedded and also in the lower layer, Results>Pressure>Parameter value (K(m/s)). It is 

unambiguous that streamlines (black) break at the layer boundaries. It is instructive recalling 

the law of refraction of current lines from Geoelectrical Methods, 

 

Figure 7.4 Effect of hydraulic conductivity of the bedded layer on the groundwater flow. Darcy flux 

magnitude, Darcy flux lines (black) and head isocontours (white) at different hydraulic conductivities 

of the middle layer: (a) K=10
-4

 m/s (homogeneous), (b) K=10
-5

 m/s and (c) K=10
-6

 m/s. 

http://gali.web.elte.hu/assets/geoelektromos-kutat%c3%b3m%c3%b3dszer.pdf


Groundwater Flow 

56 
 

 2211 tantan  , (7.2) 

where ρ and α denote the resistivity and the angle from the axis of incidence in medium 1 and 

2. Eq. (7.2) proves that if the current enter the medium 2 with higher resistivity (ρ2>ρ1), the 

angle tends to the axis on incidence (α2<α1), since tangent is a monotonic increasing function 

within the range of α=0–90º. The analogy between the water flow and current flow is strong, 

Figure 7.4 validates that the flow enters from the upper layer to the middle, clayey layer with 

lower conductivity (higher resistivity), the flow paths break toward the axis of incidence, so α 

decreases. 

 We can investigate how the head and velocity profiles vary e.g. along the left-hand 

side of the inhomogeneous model, Results>1D Plot Group>Line Graph>Selection: #1, 3, 5 

(left side), Expression: dl.H, and x-Axis Data>Parameter>Expression: y, then Plot. As the 

hydraulic conductivity of the bedded layer decreases, the head is enhanced in the upper layer, 

but it is reduced in the deeper layers. The vertical velocity along this profile, Expression: 

dl.v, is lower, when K is decreased. The low-conductivity clayey layer retains the flow, so its 

role is similar to the increase in anisotropy. Save As>Groundwater flow - 3-layer. 

 

7.1.4 Inhomogeneity 

 

 Another kind of heterogeneity occurring in geological situations is an embedded 

clayey lens, Geometry_R>Ellipse>Size and Shape>a-semiaxis: 30 m and b-semiaxis: 10 m 

at a Position: (100, -50) m related to the Base: Corner. Press BAO. 

 Suppose that the hydraulic conductivity of the clayey layer and the lens is less by one 

order of magnitude, Darcy’s Law>Fluid and Matrix Properties 2>Selection: #2, 4 (bedded 

layer and lens), Matrix Properties>Hydraulic conductivity: 1e-5 m/s. To refine the 

discretization around the lens, Mesh_R>Size, move Size 2 above Free Triangular, and 

GEL>Domain>Selection: #4 (lens), then Custom>MES: 3 m and BA. The new model 

geometry is recovered by 18508 finite elements. Now, you must delete parametric sweep, 

Study 1>Parametric Sweep_R>Delete, and you can solve the problem, Study 1>Compute. 

 Darcy flux maximums appear at the ‘corner’ of the clayey lens, where the flow 

accelerates to avoid the aquitard. Negative values of the horizontal velocity, 

Results>Pressure>Surface>Expression: dl.u, become visible near the surface of the lens, 

which were not present earlier in the model. This solution will be the initial condition of the 

next model including contaminant transport, so Save As>Groundwater flow - 

inhomogeneity. 

 

7.2 Pollutant transport in groundwater flow 
 

 In this model the effect of a point-like pollutant emitter will be investigated. Although 

the near-surface source operates only one day long, still the pollution is dissolved and 

transported in the groundwater flow. In order to handle numerically the solution transport in 

porous medium, we need to add a new module, Component 1_R>Add Physics>Chemical 

Species Transport>Transport of Diluted Species in Porous Media (tds). Change 

Equation>Equation form>Time dependent to see the relation describing the time-

dependence of the solute concentration (1
st
 term), which depends on the time-dependent rock 

structure (porosity), the molecular diffusion, the advection, the reaction and source terms 

(from left to right) as it was studied in the course of Earth’s Flow Systems I. Let us click 

Dispersion to include this specific property (mechanical dispersion) of flow in porous 

medium. 

http://gali.web.elte.hu/assets/f%c3%b6ldi-%c3%a1raml%c3%a1sok-fizk%c3%a1ja.pdf
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 We need to slightly modify the Geometry_R>Point: (100, -1) m to locate the 

pollutant point source just below the surface, BAO. Back to Transport of Diluted Species in 

Porous Media>Porous Media Transport Properties>Velocity field: Darcy’s velocity field 
we can couple the two equations (Darcy’s Law and mass transport equation), which is the 

strength of COMSOL. In this model the Darcy flux driven by water table topography 

influences the concentration distribution through advection and dispersion terms, but the 

concentration does not control the flow, supposing that the solute concentration is low to 

considerably increase the water density. Thus, it is a partly coupled PDE system. We need to 

define Porosity: 0.1, Effective diffusivity model>No correction, and Dispersion tensor: 

Dispersivity, Dispersivity model>Isotropic>Longitudinal dispersivity: 1 m and 

Transverse dispersivity: 1 m for the whole model domain. To define the point source, 

Transport of Diluted Species in Porous Media_R>Points>Line Mass Source>Point 

Selection: #6 (pollutant point source defined above). The point source contaminates the soil 

one day long, Species Source: t<1 [d]. 

 To actualize the mesh in the surroundings of the point source, Mesh_R>Size, move 

Size 3 above Free Triangular, and choose GEL>Point: #6 (point source), Custom>MES: 

0.5 m, then BA, and the model geometry will be covered by 18910 finite elements. 

 Now, we are going to study the time-dependent transport of the contamination, thus 

we need a new study, Groundwater flow - inhomogeneity.mph_R>Add Study>Time 

Dependent. We can prepare the settings during the time-dependent solution, Study 2_R>Get 

Initial Value, then Results>Concentration_R>Arrow Surface>Coloring and 

Style>Arrow length: Normalized. To set the parameters characterizing the time-dependence 

of the study, Study 2>Step 1: Time Dependent>Time unit: d and Times: range(0, 1, 

120) d, which is about four months. We would like to follow the variation of the solute 

concentration during the solution, Results While Solving>Plot>Plot Group: Concentration 

for each time step, Update at: Time steps taken by solver. We should not forget to regulate 

the time stepping, Study 2>Solver Configurations>Solution 2>Time-Dependent 

Solver>Time Stepping>Steps taken by solver: Strict. Now, we can start, 

Study 2>Compute. 

 During the solution you can follow the time-dependent contamination transport in the 

model in Graphics window (Figure 7.5). In Progress and Log menu below Graphics the 

chosen calculation method, time, time steps, output times etc. are presented. It is clear that the 

flow field does not vary in time, since the concentration does not influence the water density, 

and the water table is fixed. After 1 day the extension of the concentration anomaly increases, 

while the concentration maximum decreases due to the molecular diffusion and mechanical 

dispersion. The contaminated water is transferred from the recharge zone toward the 

discharge zone by advection, which results in that the pollutant penetrates deeper. One part of 

the contamination is trapped in the clayey lens and retained by the low-conductivity medium, 

thus the anomaly parts. Generally, it can be established that the main transport process in this 

model is the advection, while the role of diffusion and dispersion are less, but not negligible, 

since it causes the spreading of the contaminating substance. Finally, we can see e.g. the time-

variation of the concentration in the position of the original point source, Results_R>1D Plot 

Group>Data>Data set: Study 2/Solution 2, 1D Plot Group_R>Point Graph>Selection: 

#6 (point source), Expression: c and Plot. We see that the concentration is high at the 

beginning, while the pollutant source is functioning, then c decreases owing to the processes 

of advection, diffusion and dispersion. Also this solution should be saved, Save As>Solute 

transport. 
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Figure 7.5 Snapshots of pollutant transport in inhomogeneous groundwater flow system. (a) Initial 

state (t=0), (b) after 20 d, (c) after 40 d, (d) after 60 d, (e) after 80 d, (f) after 100 d, and (g) after 120 d. 

Coloring denotes the concentration of the contamination. Darcy flux direction is shown by red arrows. 
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7.2.1 Effect of well 

 

 The main question is:  How can be the polluted water removed from the subsurface? 

One possible solution is that one or more wells must be pumped around the contamination, so 

the polluted water can be discharged from the aquifer. As we will see, it is not trivial to plan 

e.g. the appropriate number, areal distribution, discharge rate of wells. The well in our 

numerical model will be imitated by a line segment, which is rather a drain when 2D is 

expanded to 3D. But there is no perfect solution for modeling a well in 2D, 

Geometry_R>Line Segment>Start Point>Specify>Coordinates: (400, 0) m to 

Endpoint>Specify>Coordinates: (400, -80) m, then BAO. We will use also a probe to 

measure the efficiency of the well pumping, Definitions_R>Probes>Domain 

Probe>Variable name: c_tot, Probe Type>Type: Integral, Expression: c, which calculates 

how the total/integrated concentration of pollutant water reduces in the model. To set the ‘2D 

pumping well’ Darcy’s Law_R>Flux Discontinuity>Boundary Selection>Selection: #8 

(well), Inward mass flux: -0.1 kg/(m
2
s), which would result in about 300 l/min discharge 

rate for a typical 2D water well. Now, we do not need the pollutant source, Transport of 

Diluted Species in Porous Media>Line Mass Source_R>Disable. 

 In order to refine the discreatization around the well, Mesh_R>Size, move Size 4 

above Free Triangular, then GEL>Boundary>Selection: #8 (well), Custom>MES: 2 m. 

Clicking BA yields 19814 finite elements. Now, we can continue the calculation by 

Study 2>Step 1: Time Dependent>Times: range(120, 1, 240) d. This setting, however, does 

not mean that the calculation will be continued from the final result! It configures only the 

start, output and stop times. To set the initial condition as a final result of the earlier study, 

Study 2>Solver configuration>Solution 2>Dependent Variables>General>Defined by 

study step: User defined, Initial Values of Variables Solved For>Method: Solution, 

Solution: Solution 2, Time (d): 120. Now, it is suggested to decrease the maximum time 

step, Study 2>Solver configuration>Solution 2>Time-Dependent Solver>Time Stepping> 

Maximum step: 0.5 d, which is half of the output time step. We might need to reset time 

settings here, General>Defined by study steps: Step 1: Time Dependent. So, we can start 

the ‘environmental precalculation’, Study 2>Compute. 

 The solution visualized in Graphics window says that the arrows showing the flow 

direction change, the local flow generated by the pumping well overwrites the topography-

driven regional groundwater flow near the well (Figure 7.6). The pollution moves toward the 

well, but cannot inhibit the penetration into the clayey layer. Probe Plot illustrates that the 

total contamination decreases in the model, at the beginning of the calculation c decreases 

quickly, but when the pollution enters the low-permeability clayey layer (at approx. 140 d), 

the rate of reduction moderates. In the meantime, the size of the anomaly increases, and the 

magnitude of the anomaly decreases due to diffusion and dispersion processes. In general, the 

pumping well facilitated the reduction of pollutant concentration; however the tested solution 

was not perfect. E.g. the well was too far from the actual position of the contamination, so 

partly aided the pollution to penetrate deeper. That is why the role of numerical modeling is 

very important in the subsurface contamination transport, too. We have to keep the model, 

Save As>Solute transport & well. 
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Figure 7.6 Snapshots of pollutant transport in inhomogeneous groundwater flow system including a 

pumping well at x=400 m. (a) t=120 d (start of pumping), (b) t=140 d, (c) t=160 d, (d) t=180 d, (e) 

t=200 d, (f) t=220 d and (g) t=240 d. Coloring denotes the concentration of the contamination. Darcy 

flux direction is shown by red arrows. 
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8 MANTLE CONVECTION 
 

 Numerical modeling of mantle convection is a typical ‘multiphysical’ problem, since 

the unknowns of the thermal convection occurring in the mantle are the pressure, the flow 

velocity and the temperature. The pressure and the velocity is solved by the conservation of 

mass and Navier–Stokes equation, while the temperature is computed from heat transport 

equation. In this final part the PDE system is fully coupled, because the temperature depends 

on the flow field, and the velocity depends on the temperature due to thermal buoyancy. The 

second part deals with the problem of thermochemical mantle convection, in which also the 

mass transport equation is coupled to the former PDEs, to build up an imposing multiphysical 

numerical model. 

 

8.1 Thermal mantle convection 
 

 In this model the higher temperature at the base of mantle ensures the driving force 

that is the thermal buoyancy for the mantle convection. Higher temperature decreases the 

density of the mantle material due to heat expansion, and induces thermal buoyancy force and 

ascending of the fluid. When the fluid reaches the cold surface, it starts cooling, its density is 

increasing, then it descends to the bottom. Moving along the hot core mantle boundary 

(CMB) the mantle is warming up, its density is decreasing, and the circulation begins from the 

start. To model thermal mantle convection as simple as possible, Model Wizard>2D>Fluid 

Flow>Nonisothermal Flow>Laminar Flow>Add, which is one of the predefined modules 

including coupled PDEs in COMSOL. The unknowns are the pressure p, the three 

components of the velocity (u, v and w at least in 3D) and the temperature T. Then click 

Study>Time Dependent>Done. 

 First, the model parameters needs defining in Global Definitions>Parameters after 

Table 8.1. In addition, we will use model variables as well, r denotes the radius and rho 

defines the linear relation between the density and the temperature (Table 8.2). 

 

Name Expression Value Description 

R0 6370 [km] 6.37E6 m Earth radius 

R1 3480 [km] 3.48E6 m Core radius 

T0 300 [K] 300 K Surface temperature 

T1 3200 [K] 3200K CMB temperature 

rho0 3300 [kg/m^3] 3300 kg/m
3
 Surface density 

g 10 [m/s^2] 10 m/s
2
 Gravitational acceleration 

alpha 2E-5 [1/K] 2E-5 1/K Heat expansion coefficient 

Table 8.1 Model constants 

 

Name Expression Unit Description 

r sqrt(x^2+y^2) m Radius 

rho rho0*(1-alpha*(comp1.T-T0)) kg/m
3
 Mantle density 

Table 8.2 Model variables 

 

 Next step is the geometry building, Geometry_R>Circle>Radius: R0, and 

Geometry>Circle_R>Duplicate>Radius R1, then BAO. To cut the ‘core’ from the ‘Earth’, 

Geometry_R>Booleans and Partitions>Difference>Objects to add: c1 (‘Earth’), and 

Objects to subtract: c2 (‘core’), then BAO again to get the ‘mantle’. In order to minimize 

the time and memory requirement, we will solve the problem only on the one fourth of the 

model domain, Geometry_R>Square>Size>Side length: 2*R0 at Position: (-2*R0, -R0) 
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then Geometry>Square_R>Duplicate, Geometry>Square 2>Position: (0, -2*R0), then 

BAO. To make a difference, Geometry_R> Booleans and Partitions>Difference>Objects 

to add: diff1 (‘mantle’), and Objects to subtract: sq1, sq2 (two squares), then BAO to get 

quadrant of the ‘mantle’ as the final model geometry. Click Zoom Extents. 

 Now, we specify the model for the flow. To see the equations, Laminar Flow 

(spf)>Equation, you can identify the Navier–Stokes equation (NS) ensuring the momentum 

conservation and the continuity equation governing the mass conservation in the system. In 

NS the inertia term (left) is balanced by the right terms: pressure gradient, viscous force and 

possible external force, for example Lorentz force. Continuity equation is valid also for 

compressible fluid, so we can simplify the problem to Physical Model>Compressibility: 

Incompressible flow, but the gravitational force is essential, click Include gravity to modify 

NS. Of course, you must designate the downward direction, which varies in the model, 

Laminar Flow>Gravity>Acceleration of gravity>g: (-x/r*g, -y/r*g). We can add the 

physical parameters, Laminar Flow>Fluid Properties>Dynamic viscosity: 1e22 Pas. If the 

dynamic viscosity depends on the temperature, pressure or/and the stress, it can be defined as 

a variable. We allow to be moving along the boundaries (free slip), Laminar 

Flow>Wall>Wall condition>Slip. Finally, we need to use a pressure constraint, because only 

the gradient of the pressure acts in NS, for this we have to switch on Advanced Physics 

Option at the top of Model Builder window. So, Laminar Flow_R>Points>Pressure Point 

Constraint>Point Selection: #2 (surface), where the pressure is fixed to zero, Pressure>p0: 

0. 

 Now, we can skip to the thermal parameters, Heat Transfer in Fluids (ht)>Equation 

shows that the heat of the fluid parcel depends on the heat advection, heat conduction, heat 

production, external heat flux, pressure work and the viscous dissipation as it was studied 

during the course of Earth’s Flow Systems II. To define the necessary parameters, Heat 

Transfer in Fluids>Fluid>Thermal conductivity>User defined>k: 5.4 W/(m K), 

Density>rho: rho (as a temperature-dependent fluid density), Heat capacity at constant 

pressure>Cp: 1200 J/(kgK), Ratio of specific heats>γ: 1, which affirms that there is no 

difference between specific heat at given pressure and at given volume. In Heat Transfer in 

Fluids>Initial Values we will define a perturbed conductive temperature state to facilitate the 

start of convective motion, e.g. 

 




























x

y

RR

Rr
TTRr

RR

TT
TT atan2sinsin)(1.0)(

10

1

011

10

01

1 , (8.1) 

which results in a positive temperature anomaly at an angle of 45º. Thermal insulation, as 

boundary condition is appropriate for the side walls, but the surface, Heat Transfer in 

Fluids_R>Temperature>Boundary Selection: #4 (surface), T0: T0, and the CMB, Heat 

Transfer in Fluids_R>Temperature>Boundary Selection: #3 (CMB), T0: T1 is 

isothermal. 

 It is suggested switching of the automatic coupling between modules, 

Multiphysics>Nonisothermal Flow_R>Disable, to set it manually. In this case you can 

define the temperature-dependent density in NS, Laminar Flow>Fluid 

Properties>Density>rho: rho. And, you need to define the velocity in Heat Transfer in 

Fluids>Fluid>Velocity field>u: Velocity field (spf). So, you can see how the PDEs are 

coupled. 

 We decrease the mesh size for the whole model domain, Mesh_R>Size, 

Size>Custom>MES: 100000 m, and for the boundaries, where thermal boundary layers 

could evolve in supercritical Rayleigh number convection, Mesh>Size 1>GEL: Boundary, 

http://gali.web.elte.hu/assets/f%c3%b6ldi-%c3%a1raml%c3%a1sok-fizk%c3%a1ja.pdf
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Selection: All, and Custom>MES: 30000 m. We use triangles for discretization, 

Mesh_R>Free Triangular, then BA to get 12719 finite elements. 

 Before starting the computation we can check the initial settings and tune the 

visualization properties, Study_R>Get Initial Value. In Results>Temperature>Surface 

you can see the perturbed conductive temperature defined above. Please, change the color 

scale to Coring and Style>Color table: Rainbow. It is useful to display also the flow 

directions, Temperature_R>Arrow Surface>Arrow Positioning>x grid points>Points: 30 

and y grid points>Points: 30, Coloring and Style>Arrow length: Normalized, Color: 

Black. 

 Turning back to the solver, Study 1>Step 1: Time Dependent>Time unit: a, Times: 

range(0, 1e6, 1e8) a. To see the temperature field and flow direction during the solution, 

Results While Solving>Plot>Plot Group: Temperature at each time steps, Update at: 

Time steps taken by solver. We refine the time stepping, Study 1>Solver 

Configurations>Solution 1>Time-Dependent Solver>Time Stepping>Steps taken by 

solver: Strict and Maximum step: 3e5 a. Let us start the simulation, Study 1>Compute. 

 Figure 8.1a shows that the temperature anomaly at 45º evolves to a large thermal 

instability and reaches the surface after 7–9 Myr. After approx. 20 Myr the warm fluid is 

located in the upper part of the mantle, and cold fluid are spread above the CMB (Figure 

8.1b). Temporarily, it seems a stable situation, cold, dense mantle is below the hot, light one. 

However, the cold upper boundary cools the warm fluid, and vice versa, hot lower boundary 

warms up the cold fluid. Since this process occurs by heat conduction, it is very slow and 

endures over 100 Myr. It is suggested saving the model before continuation, Save>Thermal 

mantle convection. 

 Actually, the phenomenon modeled above is only a transient state, so, if we want to 

see the flow similarly to the real mantle convection, we need to continue the calculation. But 

first, we define some probe plots to quantify the flow, 

 Definitions_R>Probes>Boundary Probe>Variable name: q_surf, as the surface 

heat flux, Source Selection>Selection: #4 (surface), Expression: ht.ntflux (normal 

total heat flux) in Table and plot unit: mW/m
2
, then Table and Window 

Setting>Plot window>+ (Add Plot Window): Probe Plot 1. 

 You can duplicate this probe plot to calculate surface velocity, Definitions>Boundary 

Pobe 1_R>Duplicate>Variable name: v_surf, Expression: spf.U (velocity 

magnitude) in Table and plot unit: cm/yr, then Table and Window Setting>Plot 

window>+ (Add Plot Window): Probe Plot 1. 

 To calculate the average mantle temperature, Definitions_R>Probes>Domain 

Probe>Variable name: T_av, Expression: T, then Table and Window 

Setting>Plot window>+ (Add Plot Window): Probe Plot 3. 

  For the continuation of the calculation, Study 1>Step 1: Time Dependent>Times: 

range(1e8, 2e6, 1e9) a, and Study 1>Solver Configurations>Solution 1>Time-Dependent 

Solver 1>Time Stepping>Maximum step: 1e6 a. It is very important to set the initial 

condition, Study 1>Solver Configurations>Solution 1>Dependent Variables 1>General> 

Defined by study step: User defined, Initial values of Variables Solved For>Method: 

Solution, Solution: Solution 1 and Time (a): 1E8. Now, we can continue the simulation 

from the end of the former solution, Study 1>Compute. 

 During the solution you can see, how cold instabilities forms from the upper cold 

surface and try to penetrate the upper hot zone. As their negative thermal buoyancy reduces, 

they become trapped in the hot zone. However, cold instabilities are able to cool down the 

upper hot mantle domain (Figure 8.1c). The process occurring above the CMB is very similar. 

By the time the cold/hot thermal instabilities cool down/heat up the upper/lower part of the 

mantle, thermal mantle convection will have been evolved (Figure 8.1d). Since neither the 
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surface heat flux/velocity nor the average temperature did not reach the quasi-stationary state, 

we should continue the simulation after Save As>Thermal mantle convection_t1e9yr. For 

the continuation of the simulation, Study 1>Step 1: Time Dependent>Times: range(1e9, 

2e6, 2e9) a, and Study 1>Solver Configurations>Solution 1>Dependent 

Variables 1>Initial Values of Variables Solved For>Time (a): 1E9, then 

Study 1>Compute. 

 During this third run a typical convective system is forming, hot plumes are emerging 

from the hot CMB, while cold downwellings are descending down into the warm mantle. 

 

Figure 8.1 Snapshots of the temperature field and the flow velocity direction (black arrow) of 

thermal mantle convection at (a) t=8 Myr, (b) t=20 Myr, (c) t=260 Myr, (d) t=1000 Myr and (e) 

t=2000 Myr. 
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Plumes are drifted toward a side walls (slip flow condition), while a cold downwelling is 

stabilized at approx. 45º. The solution is time-dependent, hot and cold instabilities are 

forming form the thermal boundary layers. Meanwhile, the surface heat flux and the velocity 

begins to reach the quasi-stationary state tending to about 100–110 mW/m
2
 and 2 cm/yr, 

respectively, which are in accordance with the observation in spite of the simplicity of the 

numerical model. The average temperature is still decreasing, because this monitoring 

parameter is stabilizing the most slowly. Figure 8.1e illustrates the final result, which will be 

the initial state of the following thermochemical mantle convection model. But previously, we 

need to save the solution, Save As>Thermal mantle convection_t2e9yr. 

 

8.2 Thermochemical mantle convection 
 

 Based on the newest seismological findings it is obvious that the mantle is not 

homogeneous compositionally. Two large low shear velocity provinces (LLSVP) were 

detected beneath Africa and Pacific by seismic tomography. In LLSVPs the reduction of S 

wave velocity is significant (2–4%), on the other hand the, P wave velocity decrease is not 

relevant (0–1%). This fact and other observations suggest that the lowest part of the mantle is 

compositionally/chemically distinct from the overlying mantle. In this final part, we will 

compile a simple thermochemical mantle convection model in which the thermal buoyancy 

facilitates the convection in the mantle (hot material below), while the ‘chemical buoyancy’ 

hinders it (compositionally dense material below). The competition of these two contrary 

effects forms the thermochemical convection in the mantle (for details see the notes of Earth’s 

Flow Systems II). 

 To handle the effect of chemical buoyancy, we need to add another module to the PDE 

system governing the non-isothermal flow problem, Component 1_R>Add 

Physics>Chemical Species Transport>Transport of Diluted Species, Settings >Equation 

shows that the time-dependence of concentration of the dense material is influenced by the 

diffusion, the advection and other reaction/source terms on the right side. We must define that 

the density of the chemically dense mantle material is higher by 1%, add another parameter to 

Global Definitions>Parameters, Name: beta, Expression: 0.01 and Description: Initial 

relative density contrast. Back to the Transport of Diluted Species>Transport 

properties>Convection>Velocity field: Velocity field (spf), which establishes that the 

velocity in the advection term in the mass transport equation is derived from the velocity 

computed from NS. Since the mantle is solid, the molecular diffusion of the dense material is 

negligible, so Diffusion>Diffusion coefficient>Dc: 0. We might set that the temperature can 

be obtained from the heat transport equation, Model input>Temperature>T: Temperature 

(ht), although the concentration is independent of the temperature, therefore it does not have 

influence on the solution. It is very important to define the initial condition for the dense 

material concentration. The primordial location, arrangement and type of the dense zone is 

very questionable and not solved problem. One of the most frequently used initial condition is 

a dense layer blanketing the Earth’s core. Thus, we suppose a layer with a thickness of 

300 km directly above the CMB, which has a continuous transition from the light upper part 

to the dense lowest part of the mantle. This transition is described by the Heaviside function, 

Transport of Diluted Species>Initial Values>Concentration>c: flc1hs((R1+300[km]-

r)[1/m], 25000), which says that the dense (c=1) layer is 300 km thick, it is located above the 

CMB (R1), and the thickness of the transition from light to dense mantle material is 50 km 

(25000 m is the half-width of the transition). 

 Perhaps, the most difficult part of the model is the appropriate setting of the initial 

conditions. The initial temperature and the velocity field is the final result of the former 

solution of thermal mantle convection at a time of 2∙10
9
 yr. On the other hand, the 

http://gali.web.elte.hu/assets/f%c3%b6ldi-%c3%a1raml%c3%a1sok-fizk%c3%a1ja.pdf
http://gali.web.elte.hu/assets/f%c3%b6ldi-%c3%a1raml%c3%a1sok-fizk%c3%a1ja.pdf
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concentration should be started from the initial value. To do this, Study 1>Solver 

Configurations>Solution 1>Dependent Variables>General>Defined by study step: 

Step 1: Time Dependent, and you should click off Study 1>Step 1: Time-Dependent: 

Transport of Diluted Species, not to solve this module. In order to get the temperature and 

the velocity field from the end of the former simulation, Values of dependent 

variables>Initial values of variables solved for>Settings: User controlled, Method: 

Solution, Study: Study 1 and Time (a): Last. In order to get the concentration from the 

initial value defined above, Values of variables not solved for>Settings: User controlled, 

Method: Initial expression, Study: Study 1 and Time (a): Last. Now, we can check the 

initial conditions, Study 1_R>Get Initial Value. 

 After this, we can prepare the plot what we want to see during the simulation, 

Results_R>2D Plot Group and 2D Plot Group_R>Surface>Expression: c within the 

Range>Manual color range: -0.1 to 1.1. It is worth renaming the plot, 2D Plot 

Group_R>Rename: Concentration. To illustrate also the temperature contours in this plot, 

Results>Concentration_R>Contour>Expression: T, Levels>Number of levels>Total 

levels: 10, and we will not need the color legends, so click off Color legend. Figure 8.2a 

illustrates the initial condition of the concentration and temperature field of the 

thermochemical mantle convection model. 

 In the thermochemical model, it is clear, that the mantle density depends both the 

 

Figure 8.2 Snapshots of the concentration of the dense material and the temperature (contours) in the 

thermochemical mantle convection model at a time of (a) t=0 Myr, (b) t=60 Myr, (c) t=150 Myr and (d) 

t=200 Myr. 
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temperature and the concentration of the dense material, Global Definitions>Variables> 

rho>Expression: rho0*(1-alpha*(comp1.T-T0)+beta*comp1.c [m^3/mol]). 

 Finally, we need to set the parameter of time-dependent solution, Study 1>Step 1: 

Time Dependent>Times: range(0, 1e6, 2e8) a, to see the time-variation of the concentration 

during the solution, Results While Solving>Plot Group: Concentration, and you should not 

forget to click Physics and Variables Selection>Transport of Diluted Species to solve the 

coupled thermochemical problem. To stabilize the computation, Study 1>Solver 

Configurations>Solution 1>Time-Dependent Solver>Time Stepping>Initial step: 1e3 a 

and Maximum step: 3e5 a. Now, we can start the solution, Study 1>Compute. 

 After 60 Myr a depression forms beneath the cold and thermally dense downwelling, 

while the compositionally dense mantle is lifted up along the side walls and within the model 

by ascending hot plumes (Figure 8.2b). Figure 8.3c displays that the primordial dense layer 

disintegrated after 150 Myr. Dense layer around the CMB retains the heat from below and 

moderates the intensity of convection, as a consequence both the surface heat flux (from 108 

to 76 mW/m
2
) and surface velocity (from 2.2 to 1.1 cm/yr) decreases (Probe Plot 1 and 2). 

The average temperature shows a long-term decreasing trend. 

 Buoyancy ratio defines the ratio of the stabilizing chemical buoyancy and the 

destabilizing thermal buoyancy, 
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where α and β denotes the heat expansion coefficient and the initial compositional density 

difference between the dense and light mantle material, as well as Δc and ΔT are the 

maximum concentration and temperature difference in the model. The value of B≈0.17<1 

indicates that the effect of thermal destabilization is stronger, so the disintegration, the 

breaking-up, then the homogenization of the primordial dense layer is expectable during 

geological time scale. At higher compositional density difference β, that is larger buoyancy 

ratio B, the evolution of the thermochemical mixing is slowed down. The process of 

thermochemical convection can be continued in a manner presented in the previous part to 

accomplish the simulation till the homogenization of the dense layer. This model should be 

saved, Save as>Thermochemical mantle convection. 
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